summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-07 15:51:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-07 16:19:04 +0100
commit20efb1635902aff77b579f640d83e7fec9cba1ea (patch)
tree5cf8bd71425a9c0b446c82227755dae9b91cf634 /dev-python/hatch-vcs
parentdev-python/comm: Bump to 0.2.0 (diff)
downloadgentoo-20efb1635902aff77b579f640d83e7fec9cba1ea.tar.gz
gentoo-20efb1635902aff77b579f640d83e7fec9cba1ea.tar.bz2
gentoo-20efb1635902aff77b579f640d83e7fec9cba1ea.zip
dev-python/hatch-vcs: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatch-vcs')
-rw-r--r--dev-python/hatch-vcs/Manifest1
-rw-r--r--dev-python/hatch-vcs/hatch-vcs-0.4.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/hatch-vcs/Manifest b/dev-python/hatch-vcs/Manifest
index 13c3c01cb31e..db6cd674215e 100644
--- a/dev-python/hatch-vcs/Manifest
+++ b/dev-python/hatch-vcs/Manifest
@@ -1 +1,2 @@
DIST hatch-vcs-0.3.0.gh.tar.gz 10049 BLAKE2B 69f49e205b4e42b46a246cc2403d8e7bbd2b8f83a360f1100ba98ecf7308d445e265749bd1f5fa7cca84104436e2643fd3f95292f2dba3dc48584a0df5136136 SHA512 ce22937aae8130a485ab154378f6c58c1720d66d277349a95ccfb58fd748deb69cd17d34ec3a12f3201f9e348e5d5b1c6b977432e614bb42d0e3065ec5f7f9c6
+DIST hatch-vcs-0.4.0.gh.tar.gz 10822 BLAKE2B 92b1ad1181a6bae815a6d01045836976b8767086f2a7001de9ad97f0d61737895da9a411419e28c5b2d830fca606d7d9c21265210965bc7691670f92aeab1b22 SHA512 bf40cc371c8d8e120fce83e5986fc2bdc2087fa5a4ac4a407d32617e98205ded79dcb29a00c7638ba68dd5ce09f31e84b34176627a6a34dfb7708031f4c4519a
diff --git a/dev-python/hatch-vcs/hatch-vcs-0.4.0.ebuild b/dev-python/hatch-vcs/hatch-vcs-0.4.0.ebuild
new file mode 100644
index 000000000000..2f7da06dc672
--- /dev/null
+++ b/dev-python/hatch-vcs/hatch-vcs-0.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Hatch plugin for versioning with your preferred VCS"
+HOMEPAGE="
+ https://pypi.org/project/hatch-vcs/
+ https://github.com/ofek/hatch-vcs/
+"
+SRC_URI="
+ https://github.com/ofek/hatch-vcs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/setuptools-scm-6.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest