summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-06-24 09:56:12 -0500
committerKacper Kowalik <xarthisius@gentoo.org>2016-06-24 09:56:12 -0500
commitf86e8a03a1ebb59f5433c007b612ffe4b2747679 (patch)
tree83b16a2fe78e3f507e24e51617740b86bcd0760d /dev-python/hglib
parentapp-misc/grabcartoons: remove git-r3 eclass, eapi bump (diff)
downloadgentoo-f86e8a03a1ebb59f5433c007b612ffe4b2747679.tar.gz
gentoo-f86e8a03a1ebb59f5433c007b612ffe4b2747679.tar.bz2
gentoo-f86e8a03a1ebb59f5433c007b612ffe4b2747679.zip
dev-python/hglib: version bump, drop old
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/hglib')
-rw-r--r--dev-python/hglib/Manifest2
-rw-r--r--dev-python/hglib/hglib-2.1.ebuild (renamed from dev-python/hglib/hglib-1.0.ebuild)10
2 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/hglib/Manifest b/dev-python/hglib/Manifest
index bee1d39f0a93..c32caec974f1 100644
--- a/dev-python/hglib/Manifest
+++ b/dev-python/hglib/Manifest
@@ -1,2 +1,2 @@
-DIST python-hglib-1.0.tar.gz 27833 SHA256 766458699a9f2e5f351bfe73164e4f8c30290d10a097aefacd25532f315b3099 SHA512 9c0a61299779aff613131aaabbc255c8648f0fa7ab1806af53f19fbdcece0c8a68ddca7880d25b926d67ff1b9201954b207919fb09f6a290acb078e8bbed7b68 WHIRLPOOL edb5dddcbe7a1f6d94ca76d6f78a2b3a53bd56c15e55ef5810ae32f07d270fd45be8947cb8eadbca3dac2de945e97f63cddd46c90157b688032b79f48b7d29bc
DIST python-hglib-1.5.tar.gz 27812 SHA256 601c04d8daa806768e3075786ffe9b93ad3574ad2b300107dd615dbe7846a367 SHA512 2506e2ac95488830b90f5f099d231e45833a8f19ce14fc2f3391ae1bf48ca72187b6b57afb633ecbe6cd2c6f3d3f482d75e03ea36406b3a07085ed1b4ef9c6b5 WHIRLPOOL 84e0cdc82344cbe3872f70d9d95ec41da4bb99e3fcece0759dea58d727ca9d650449cba1ef9ca214b954942c801363b7e8fc2fbb1abf6e6a0eb7b8133855c7c1
+DIST python-hglib-2.1.tar.gz 29030 SHA256 aef394edeeea89803f9764a441423da3efffefaae9cf0eca6ee38cdb4ac00d73 SHA512 82cd00e4184a8a002ea0bcc2dec4de06a705f5f6cecd1ddbddef08ead2817f673590884aee5187fbc3496ced3f27ca8c8d78e0436fb97205ef654cd28d912e68 WHIRLPOOL 248b37b1ef0ff8a0d5f3ecaa9defd2e72f2cd661922847eef4f9501e6a313af9cdc6a6bac774d2aed1b79ad7ab9bb04cd639431376b3502ad75b97ad26a6d6e7
diff --git a/dev-python/hglib/hglib-1.0.ebuild b/dev-python/hglib/hglib-2.1.ebuild
index 42ab6ed2759f..671cdfc92b20 100644
--- a/dev-python/hglib/hglib-1.0.ebuild
+++ b/dev-python/hglib/hglib-2.1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
PYTHON_REQ_USE="threads(+)"
-MY_P="python-${P}"
-MY_PN="python-${PN}"
+MY_P=python-${P}
+MY_PN=python-${PN}
inherit distutils-r1
@@ -26,8 +26,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
S=${WORKDIR}/${MY_P}
-PATCHES=( "${FILESDIR}"/${PN}-0.3-tests.patch )
-
python_test() {
if ! ${PYTHON} test.py; then
die "Tests failed under ${EPYTHON}"