summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2020-06-19 18:53:24 -0700
committerMichał Górny <mgorny@gentoo.org>2020-06-21 08:19:26 +0200
commite5653f1cb4a4eea13572c29a8280ea7047c6282d (patch)
treedd53d44bb284cecc9ca72e3d6bd3ba42a0e45a32 /dev-python/icalendar
parentsci-libs/nlopt: Bump to 2.6.2 (diff)
downloadgentoo-e5653f1cb4a4eea13572c29a8280ea7047c6282d.tar.gz
gentoo-e5653f1cb4a4eea13572c29a8280ea7047c6282d.tar.bz2
gentoo-e5653f1cb4a4eea13572c29a8280ea7047c6282d.zip
dev-python/icalendar-4.0.6: bump, EAPI7, Py3.8
Signed-off-by: Christopher Head <chead@chead.ca> Closes: https://github.com/gentoo/gentoo/pull/16333 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-4.0.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 5638437fac8a..b678d7214c4c 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1 +1,2 @@
DIST icalendar-4.0.3.tar.gz 77899 BLAKE2B d4043914b85359a8309dd7c8acce55ec5921508319342f2ffb2e16017aa5aa164ef7fdd44aee7820a971516a3e157b5c8ee86732e669c8eac4b5c4bc1767e334 SHA512 2f0ac5a7f36c7d37047ba20bec3f2ca7df51a9e3ec3f29751c71cdd264c01f7e0abd6efc298dac5a7c87911cb4916e56bf77716d6ca05a2d090e26486e6a56be
+DIST icalendar-4.0.6.tar.gz 78418 BLAKE2B 4941262cca63cae4df249b6ec01b73b640caa002d011ed19aead89fdfc6fe9a7e37258d95668142137faf635403986a2ea4d3e39dd565d1205dfb238fd13e98f SHA512 e8f7ee878cc14b75636268d7b8c79569ce1875142fb907b1eb74bc6b9cf96f218e4be63828190aa2a27978c431437c1d454febe9a2da58c5f2785e283ae725b2
diff --git a/dev-python/icalendar/icalendar-4.0.6.ebuild b/dev-python/icalendar/icalendar-4.0.6.ebuild
new file mode 100644
index 000000000000..4b472fff1bc1
--- /dev/null
+++ b/dev-python/icalendar/icalendar-4.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="https://github.com/collective/icalendar"
+SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}