summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-29 14:48:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-29 14:49:31 +0200
commit33ed8811f3d3872817c1b023dfaea0c4acc23e3c (patch)
tree2e475dfc9f8208c708a4331b35a252d330b4c58c /dev-python/ini2toml
parentdev-python/jsonschema: Remove old (diff)
downloadgentoo-33ed8811f3d3872817c1b023dfaea0c4acc23e3c.tar.gz
gentoo-33ed8811f3d3872817c1b023dfaea0c4acc23e3c.tar.bz2
gentoo-33ed8811f3d3872817c1b023dfaea0c4acc23e3c.zip
dev-python/ini2toml: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest1
-rw-r--r--dev-python/ini2toml/files/ini2toml-0.10-test.patch39
-rw-r--r--dev-python/ini2toml/ini2toml-0.10.ebuild68
3 files changed, 0 insertions, 108 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index a307283e1b3b..523eea28e797 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1,2 +1 @@
-DIST ini2toml-0.10.gh.tar.gz 93535 BLAKE2B 8d8a5b31c53b9194e578b473dfd562b1b569d701b36b267ec4f59ea75ec03abd6e1df5541327b9414a2f1c04b1cb41ec57c6f900007f69a3c51a172143d2eacd SHA512 3d88f97c50a13fe3878e3fa35d70c9051874bec99d278411dcc7098d86898deb0e490be26f293e9a304d4c9a2842274e68126a2d20dac77b526161fde682dd75
DIST ini2toml-0.11.gh.tar.gz 93696 BLAKE2B 0fb52b346065421049fd377a62de4189a6d261ad12c00679c97568a0e7b7f8fc7bf1aae2196b8fc70489d547c0ce9be1347336d25769c7fb383f9fec4d4aa205 SHA512 7329fd3ba31567638fffce22f2370c2055503bd4abc3d7dab30b1828eb54204d31036753efddfab52e79703ce7583f6070e1207c95345096c0751c2d429fd6ea
diff --git a/dev-python/ini2toml/files/ini2toml-0.10-test.patch b/dev-python/ini2toml/files/ini2toml-0.10-test.patch
deleted file mode 100644
index bd1d8b093a33..000000000000
--- a/dev-python/ini2toml/files/ini2toml-0.10-test.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 1a40d273d6671657ef10081123a675bd22e4bf06 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 2 Apr 2022 18:21:39 +0200
-Subject: [PATCH] Support duplicate plugin instances in
- test_list_from_entry_points
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Account for the possibility of the isort plugin occurring more than
-once in the plugin list, in test_list_from_entry_points. This is needed
-to avoid test failures on Gentoo where tests are run in a venv
-with --system-site-packages. As a result, if ini2toml is installed
-already, it grabs all plugins twice — once from the venv, and then again
-from system site-packages directory.
----
- AUTHORS.rst | 1 +
- tests/test_plugins.py | 3 ++-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/tests/test_plugins.py b/tests/test_plugins.py
-index a1e96eb..9b52432 100644
---- a/tests/test_plugins.py
-+++ b/tests/test_plugins.py
-@@ -46,6 +46,7 @@ def test_list_from_entry_points():
- # Should return a list with all the plugins registered in the entrypoints
- pluging_list = plugins.list_from_entry_points()
- orig_len = len(pluging_list)
-+ isort_count = len([e for e in pluging_list if "isort" in str(e.__module__)])
- assert all(callable(e) for e in pluging_list)
- plugin_names = " ".join(str(e.__module__) for e in pluging_list)
- for example in EXISTING:
-@@ -54,5 +55,5 @@ def test_list_from_entry_points():
- # a filtering function can be passed to avoid loading plugins that are not needed
- pluging_list = plugins.list_from_entry_points(filtering=lambda e: e.name != "isort")
- plugin_names = " ".join(str(e.__module__) for e in pluging_list)
-- assert len(pluging_list) == orig_len - 1
-+ assert len(pluging_list) == orig_len - isort_count
- assert "isort" not in plugin_names
diff --git a/dev-python/ini2toml/ini2toml-0.10.ebuild b/dev-python/ini2toml/ini2toml-0.10.ebuild
deleted file mode 100644
index 0e0c3b630fa1..000000000000
--- a/dev-python/ini2toml/ini2toml-0.10.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
-HOMEPAGE="
- https://pypi.org/project/ini2toml/
- https://github.com/abravalheri/ini2toml/
-"
-SRC_URI="
- https://github.com/abravalheri/ini2toml/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
- >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/tomli[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-PATCHES=(
- "${FILESDIR}"/${P}-test.patch
-)
-
-EPYTEST_DESELECT=(
- # pyproject_fmt is not packaged
- tests/test_cli.py::test_auto_formatting
-
- # fails on whitespace/comments/formatting
- tests/test_translator.py::test_simple_example
- tests/test_translator.py::test_parser_opts
- tests/plugins/test_setuptools_pep621.py::test_move_entry_points_and_apply_value_processing
- tests/plugins/test_setuptools_pep621.py::test_split_subtables
- tests/plugins/test_setuptools_pep621.py::test_entrypoints_and_split_subtables
- tests/plugins/test_setuptools_pep621.py::test_handle_dynamic
-)
-
-EPYTEST_IGNORE=(
- # configupdater is not packaged
- tests/test_examples.py
- tests/test_transformations.py
- tests/drivers/test_configupdater.py
-)
-
-src_prepare() {
- sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
- distutils-r1_src_prepare
-}