summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ioflo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ioflo')
-rw-r--r--dev-python/ioflo/Manifest2
-rw-r--r--dev-python/ioflo/ioflo-1.0.2.ebuild25
-rw-r--r--dev-python/ioflo/ioflo-1.2.1.ebuild23
-rw-r--r--dev-python/ioflo/metadata.xml12
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/ioflo/Manifest b/dev-python/ioflo/Manifest
new file mode 100644
index 000000000000..f518dc026021
--- /dev/null
+++ b/dev-python/ioflo/Manifest
@@ -0,0 +1,2 @@
+DIST ioflo-1.0.2.tar.gz 665695 SHA256 e675a41089cdfd06c3186fd05148065bba91008a69837ea052f01069be2ba17f SHA512 219c319c5d1fef324632c8ac6e07d5a9fa2cfccf6024f38e298b7d4f04814528c7a613b24092d373369a8c4795b6b8954e1abb95556eed2d4fcb8f02720dad78 WHIRLPOOL 2f21817c39c8e6a3f3c8fa1d349c5e8196f47471d60b76e192ae4e24192325e8e6aedc599070b7ec4cd6066c2fb2049dc010072da4b3f196a546437164067d04
+DIST ioflo-1.2.1.tar.gz 678212 SHA256 926b8f426931e6c37c8ebf9709e5ae9031eca6aaab3de58ceb75ac20ac116125 SHA512 ee33dc44a61b53c5197cebf4d34801ad70a5d485f96054ae601904770454e1444a12b4876d44ae92cebe4aa178c877c303fb094ecb97fbce9ad255b72e85bf51 WHIRLPOOL a43dc33ff60e5ecbc1785ec51ebc7f6535446e11467709a4ff0bb328028b1a1e0df5753d3d0151dd4144c3dfae54d90bb0044f044c4d1ec6968efed5814e6fe7
diff --git a/dev-python/ioflo/ioflo-1.0.2.ebuild b/dev-python/ioflo/ioflo-1.0.2.ebuild
new file mode 100644
index 000000000000..74d511ae9016
--- /dev/null
+++ b/dev-python/ioflo/ioflo-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4})
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ pushd ${PN}/app/test || die "could not find tests"
+ ${EPYTHON} testStart.py || die "tests failed"
+ popd
+}
diff --git a/dev-python/ioflo/ioflo-1.2.1.ebuild b/dev-python/ioflo/ioflo-1.2.1.ebuild
new file mode 100644
index 000000000000..6e0acff3a5f5
--- /dev/null
+++ b/dev-python/ioflo/ioflo-1.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4})
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -c "from ioflo import test; test.run()"
+}
diff --git a/dev-python/ioflo/metadata.xml b/dev-python/ioflo/metadata.xml
new file mode 100644
index 000000000000..17e8d2634f2e
--- /dev/null
+++ b/dev-python/ioflo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">ioflo/ioflo</remote-id>
+ </upstream>
+</pkgmetadata>