summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-08 05:11:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-08 05:22:39 +0100
commit2daa064eebebfd62456afcd5efe3b0613df3dc5e (patch)
tree148cec92287d31c2e6849e68defffbc68f4064be /dev-python/jaraco-classes
parentdev-python/dogpile-cache: Bump to 1.3.1 (diff)
downloadgentoo-2daa064eebebfd62456afcd5efe3b0613df3dc5e.tar.gz
gentoo-2daa064eebebfd62456afcd5efe3b0613df3dc5e.tar.bz2
gentoo-2daa064eebebfd62456afcd5efe3b0613df3dc5e.zip
dev-python/jaraco-classes: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-classes')
-rw-r--r--dev-python/jaraco-classes/Manifest1
-rw-r--r--dev-python/jaraco-classes/jaraco-classes-3.3.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/jaraco-classes/Manifest b/dev-python/jaraco-classes/Manifest
index ea646c14a446..82850734a36c 100644
--- a/dev-python/jaraco-classes/Manifest
+++ b/dev-python/jaraco-classes/Manifest
@@ -1 +1,2 @@
DIST jaraco.classes-3.3.0.tar.gz 10729 BLAKE2B 05791a799e4d5bbce94b111e7acc922f46cf2eb409c6043f997482960ad3b4a29b0d2f9afc7f1fdc07363f0a0b6403077d685831baf909ecd93adac71611ac30 SHA512 8099c85c93ed0eff37b1f870e2577b20488dea7b10273c00a89b43c0ef759c17c9a835916eef0fd97b3944bc5cd50b32e1393ac7c80cf7c7bfd1ee0d639d16cf
+DIST jaraco.classes-3.3.1.tar.gz 11699 BLAKE2B 4510bc79d9fb0697aabfa5211c250e362048091b38dc1f6d404abc80ded078744dda29e91bc82ff30fbfe352614f3be14e1cf2cebea0ce7bd839d21b6897817d SHA512 368a45965e321506bb4a66c80ddf79e8e58f25f92bf9bbd1cffc9118f696ea23dcca6f9277544d1c2af1cbc18fe0cc5a2bdc7b9ad865f54ac0776b0b58aca90b
diff --git a/dev-python/jaraco-classes/jaraco-classes-3.3.1.ebuild b/dev-python/jaraco-classes/jaraco-classes-3.3.1.ebuild
new file mode 100644
index 000000000000..6374ebe23e5a
--- /dev/null
+++ b/dev-python/jaraco-classes/jaraco-classes-3.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Classes used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.classes/
+ https://pypi.org/project/jaraco.classes/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest