summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-17 20:36:32 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-18 10:18:29 +0100
commit7c65edd2447df29fa5be6d2b41c4c83e5ee4f2f4 (patch)
tree86d761480b1c896adcab6e849a70a3d1293be4bf /dev-python/jellyfish
parentnet-misc/openssh: mark 7.3_p1-r7 arm64/m68k/s390/sh stable (diff)
downloadgentoo-7c65edd2447df29fa5be6d2b41c4c83e5ee4f2f4.tar.gz
gentoo-7c65edd2447df29fa5be6d2b41c4c83e5ee4f2f4.tar.bz2
gentoo-7c65edd2447df29fa5be6d2b41c4c83e5ee4f2f4.zip
dev-python/jellyfish: add py3.5, doc, tests, EAPI=6
We need to build the extension in-place so that tests pass. Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3518
Diffstat (limited to 'dev-python/jellyfish')
-rw-r--r--dev-python/jellyfish/jellyfish-0.5.6.ebuild35
1 files changed, 31 insertions, 4 deletions
diff --git a/dev-python/jellyfish/jellyfish-0.5.6.ebuild b/dev-python/jellyfish/jellyfish-0.5.6.ebuild
index ec95b893abc5..3020501fbbe9 100644
--- a/dev-python/jellyfish/jellyfish-0.5.6.ebuild
+++ b/dev-python/jellyfish/jellyfish-0.5.6.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+DISTUTILS_IN_SOURCE_BUILD=1
+
inherit distutils-r1
DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
@@ -13,5 +15,30 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/unicodecsv[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile() {
+ esetup.py build_ext --inplace
+ esetup.py build
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( build/sphinx/html/. )
+ fi
+}
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+python_test() {
+ py.test jellyfish/test.py || die "tests failed with ${EPYTHON}"
+}