summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/json-rpc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/json-rpc')
-rw-r--r--dev-python/json-rpc/Manifest3
-rw-r--r--dev-python/json-rpc/json-rpc-1.10.1.ebuild28
-rw-r--r--dev-python/json-rpc/json-rpc-1.7.0.ebuild27
-rw-r--r--dev-python/json-rpc/json-rpc-1.9.2.ebuild27
-rw-r--r--dev-python/json-rpc/metadata.xml16
5 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/json-rpc/Manifest b/dev-python/json-rpc/Manifest
new file mode 100644
index 000000000000..85fea585e7d9
--- /dev/null
+++ b/dev-python/json-rpc/Manifest
@@ -0,0 +1,3 @@
+DIST json-rpc-1.10.1.tar.gz 25410 SHA256 3edffc0905a08090edb4036f8767a08826ec618f9f02717251fd2eb3e1c6983b SHA512 bb69cbb12c0a64286fb1e98db21ca75cb19daf20c6d6f5721f82891a17e44d2cda172e73bd389a02077d094b8f6deb0959952b0498b0c1b4a0acfaa5e3ba3922 WHIRLPOOL c08c465be4951055a12979de5bca056cf56e35c874f491ba4891125e9fbfcc985f85d120c2a5fcb1d8b8264487af90efb34e0316981ccf546190421df5fdc885
+DIST json-rpc-1.7.0.tar.gz 21699 SHA256 9961113fc66bb4e34abd4fa6e8eb2086d14aee88c789e00a023751b5c84dd34b SHA512 f89ae1c2da9f0fa3e3a6552ea89a13ef1806b1a5d4d03ab7c420a1648dde6980af6743a5c70d500224ad5d0d8a5aa6b74ad7de43ea3aeefb1cba0e5dc6cc5fa4 WHIRLPOOL 02bd37b82b6259b9b8fb513615499b1105a0cbbea8b4e6e37800560b6114beb237efa397bf6f50312a26e500eedd0ddc89bf798162742788200f51a563a713ab
+DIST json-rpc-1.9.2.tar.gz 25100 SHA256 42414af4aeab786bb9643c88238f91253251ce301e5f3cdbf385f778ad9b6399 SHA512 9e43c96c54dc07f1cf3d6167e978dc9cab94fd45759148302c13d665384bbc9373d588edae1a17aa06d4804b4c176900165c401ef9801c6af88f7d1af1e0b7ec WHIRLPOOL 8299a1c928394a4fd3bb8e47c535d2d749984fef7fe421d733320dde6e370dc0f2267365a252af083d324f914a6c52f8b1690bb07096e46c0ef847d09af86b9b
diff --git a/dev-python/json-rpc/json-rpc-1.10.1.ebuild b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
new file mode 100644
index 000000000000..1981501d570a
--- /dev/null
+++ b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON-RPC transport implementation for python"
+HOMEPAGE="https://github.com/pavlov99/json-rpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die
+}
diff --git a/dev-python/json-rpc/json-rpc-1.7.0.ebuild b/dev-python/json-rpc/json-rpc-1.7.0.ebuild
new file mode 100644
index 000000000000..c23d740d2bc4
--- /dev/null
+++ b/dev-python/json-rpc/json-rpc-1.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_{3,4}})
+
+inherit distutils-r1
+
+DESCRIPTION="JSON-RPC transport implementation for python"
+HOMEPAGE="https://github.com/pavlov99/json-rpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die
+}
diff --git a/dev-python/json-rpc/json-rpc-1.9.2.ebuild b/dev-python/json-rpc/json-rpc-1.9.2.ebuild
new file mode 100644
index 000000000000..45e2d772905d
--- /dev/null
+++ b/dev-python/json-rpc/json-rpc-1.9.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON-RPC transport implementation for python"
+HOMEPAGE="https://github.com/pavlov99/json-rpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die
+}
diff --git a/dev-python/json-rpc/metadata.xml b/dev-python/json-rpc/metadata.xml
new file mode 100644
index 000000000000..99af37920dca
--- /dev/null
+++ b/dev-python/json-rpc/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ JSON-RPC is a stateless, light-weight remote procedure call (RPC) protocol.
+ Primarily this specification defines several data structures and the rules
+ around their processing. It is transport agnostic in that the concepts can
+ be used within the same process, over sockets, over http, or in many various
+ message passing environments. It uses JSON (RFC 4627) as data format.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">json-rpc</remote-id>
+ <remote-id type="github">pavlov99/json-rpc</remote-id>
+ </upstream>
+</pkgmetadata>