summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-02 12:33:55 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-02 12:56:30 +0200
commita9bab88d73c3476ab7ad89933bfc7854b4240876 (patch)
tree74428fd5526ca05a4401d52fd06ef2b6a55191b9 /dev-python/jupyterlab-lsp
parentdev-python/jupyterlab_server: add 2.13.0 (diff)
downloadgentoo-a9bab88d73c3476ab7ad89933bfc7854b4240876.tar.gz
gentoo-a9bab88d73c3476ab7ad89933bfc7854b4240876.tar.bz2
gentoo-a9bab88d73c3476ab7ad89933bfc7854b4240876.zip
dev-python/jupyterlab-lsp: add 3.10.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest1
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index f8b249b45bcd..db258d89319d 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1 +1,2 @@
DIST jupyterlab-lsp-3.10.0.tar.gz 269237 BLAKE2B 379716c2dc61053f10b70969b63a62b3d8c57915c472ee04f55513236f318d787ae92257751f789a2a7fe3b6faef5141e54ef7708c76f7720eabe8edf855a28e SHA512 a62073744a6ab5d57af12e738ef754f139bf34fdcbd54921127a1273f238cbda3f9ac859f7702ab862ba5597dcd75d22c0db9423ef6c7b2ee9c3459efda3b2a5
+DIST jupyterlab-lsp-3.10.1.tar.gz 269339 BLAKE2B 18949cb5b2ae73b1beb623756d9aa316192ea0ba5074edc106e3acd8a3cc6e0803c01727ce4416a3ba0f6b2fc88def2d4c93deead33ca55c4735e8a45c48afd9 SHA512 56fccdc383ebf12572dc61f37d76c0a6aaa0021fea75ead7dbf51e9eba7e25986d9f3752f1146b6dc2cad8c565026e7354cd0c56bf32607421c6a4de0f9b5da6
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.1.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.1.ebuild
new file mode 100644
index 000000000000..46148aa982dc
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="https://github.com/jupyter-lsp/jupyterlab-lsp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-3.1.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-1.4.0[${PYTHON_USEDEP}]
+"