summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/kazoo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/kazoo')
-rw-r--r--dev-python/kazoo/Manifest3
-rw-r--r--dev-python/kazoo/kazoo-1.3.1.ebuild48
-rw-r--r--dev-python/kazoo/kazoo-2.0.ebuild44
-rw-r--r--dev-python/kazoo/kazoo-2.2.1.ebuild43
-rw-r--r--dev-python/kazoo/metadata.xml12
5 files changed, 150 insertions, 0 deletions
diff --git a/dev-python/kazoo/Manifest b/dev-python/kazoo/Manifest
new file mode 100644
index 000000000000..3a3b5e6c31cb
--- /dev/null
+++ b/dev-python/kazoo/Manifest
@@ -0,0 +1,3 @@
+DIST kazoo-1.3.1.zip 138816 SHA256 51c6dec001b0ffabeab2f1516c92999e1554d0072e517a5a39d4428decf4d7c8 SHA512 fa93210a361086ca40c2b2eebeb0062e055420cf4de4fecb94c96b9cddc5b0404135b0344cce37d7e91462c3022f348a5b007a6ec20c4bb29e1817335f1fbcc3 WHIRLPOOL 8f2ce9b9db8450bb011d59b956997406a672a38331a86b2a79b5270da1a733d086b1f88a10acf75803f64f1781bcd8f2645ab34b4daf3d397a4b8ecf1ffcc740
+DIST kazoo-2.0.zip 145663 SHA256 f0c42cc7752a331ba59269827bd19cb271210399a9dcab32b6a91465b4431a18 SHA512 99ea48e5c763adc18f579a6066a63b55b615e5bf0350e60b8e2ec1e6bb8608cbf0acf67fe7937ff6d68cb79ace765806fed38ecaf8ace600a0c20166be8d8ef4 WHIRLPOOL 00aa5257b9061c0477feac00c1ee1a92a26700cee7ab0c6ca5702a3ca03907b69f66437dbf61896ee3a95a9eb06beee85650c9f9bdf1bd9a2b3c4ba11433180f
+DIST kazoo-2.2.1.tar.gz 108037 SHA256 525a9959b98a1203530bee01446b365a9f7f1caa69399af0151127178941eb82 SHA512 a2590441a9e3bfb3d14913051453e195d275b82bd6a4ce5e32d0a7bbc09b00e475ffac68fd06cb065aa439ea580b61bbeaa3ccfefa413723e46f4b1d3ce05707 WHIRLPOOL 6e43b27683382f4fb4054b85017e94e4fddd2d1416eea1566b87fc4cbc3edce37093e8c001211d324162d35f4c0f0da3632de1cf543eef2b171971a0f05b7357
diff --git a/dev-python/kazoo/kazoo-1.3.1.ebuild b/dev-python/kazoo/kazoo-1.3.1.ebuild
new file mode 100644
index 000000000000..e303d9ee761e
--- /dev/null
+++ b/dev-python/kazoo/kazoo-1.3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high-level Python library that makes it easier to use Apache Zookeeper"
+HOMEPAGE="https://kazoo.readthedocs.org/ https://github.com/python-zk/kazoo/ https://pypi.python.org/pypi/kazoo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gevent test"
+
+RDEPEND="
+ >=dev-python/zope-interface-3.8.0[${PYTHON_USEDEP}]
+ gevent? ( dev-python/gevent[$(python_gen_usedep 'python2*')] )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+# not all test deps are in the tree
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && { sphinx-build -b html docs docs/_build/html || die; }
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ local DOCS=( {CHANGES,CONTRIBUTING,README}.rst )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/kazoo/kazoo-2.0.ebuild b/dev-python/kazoo/kazoo-2.0.ebuild
new file mode 100644
index 000000000000..37cba7e9eef9
--- /dev/null
+++ b/dev-python/kazoo/kazoo-2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high-level Python library that makes it easier to use Apache Zookeeper"
+HOMEPAGE="https://kazoo.readthedocs.org/ https://github.com/python-zk/kazoo/ https://pypi.python.org/pypi/kazoo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc gevent test"
+
+RDEPEND="
+ gevent? ( dev-python/gevent[$(python_gen_usedep 'python2*')] )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+# not all test deps are in the tree
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && { sphinx-build -b html docs docs/_build/html || die; }
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ local DOCS=( {CHANGES,CONTRIBUTING,README}.rst )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/kazoo/kazoo-2.2.1.ebuild b/dev-python/kazoo/kazoo-2.2.1.ebuild
new file mode 100644
index 000000000000..c6b13e776cc8
--- /dev/null
+++ b/dev-python/kazoo/kazoo-2.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high-level Python library that makes it easier to use Apache Zookeeper"
+HOMEPAGE="https://kazoo.readthedocs.org/ https://github.com/python-zk/kazoo/ https://pypi.python.org/pypi/kazoo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gevent test"
+
+RDEPEND="
+ gevent? ( dev-python/gevent[$(python_gen_usedep 'python2*')] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+# not all test deps are in the tree
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && { sphinx-build -b html docs docs/_build/html || die; }
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ local DOCS=( {CHANGES,CONTRIBUTING,README}.rst )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/kazoo/metadata.xml b/dev-python/kazoo/metadata.xml
new file mode 100644
index 000000000000..59a2b478a979
--- /dev/null
+++ b/dev-python/kazoo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <use>
+ <flag name="gevent">Enable support for the gevent based handler</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">kazoo</remote-id>
+ <remote-id type="github">python-zk/kazoo</remote-id>
+ </upstream>
+</pkgmetadata>