summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-06-16 14:51:44 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-06-16 15:03:30 -0700
commitcd829896a8cd07958167501f94b470728db4e2e9 (patch)
treea2b4117711ae442540e442533cdc6f22d9a20030 /dev-python/lazy-object-proxy
parentdev-vcs/cvsps: Drop 2.2_beta1 (r0) (diff)
downloadgentoo-cd829896a8cd07958167501f94b470728db4e2e9.tar.gz
gentoo-cd829896a8cd07958167501f94b470728db4e2e9.tar.bz2
gentoo-cd829896a8cd07958167501f94b470728db4e2e9.zip
dev-python/lazy-object-proxy-1.5.0: Version bump, add py39
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/lazy-object-proxy')
-rw-r--r--dev-python/lazy-object-proxy/Manifest1
-rw-r--r--dev-python/lazy-object-proxy/lazy-object-proxy-1.5.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/lazy-object-proxy/Manifest b/dev-python/lazy-object-proxy/Manifest
index efe646515ed6..a2d8b35fb2fb 100644
--- a/dev-python/lazy-object-proxy/Manifest
+++ b/dev-python/lazy-object-proxy/Manifest
@@ -1 +1,2 @@
DIST lazy-object-proxy-1.4.3.tar.gz 34888 BLAKE2B 43f64fcd6573d4a4cdc2208bcd882714cb21474e4274d53b955664b05525ed5d1305ed4121f6ee319aefb3ab7827bc9b2073d32dc4c67e969adb5367a16d4cc1 SHA512 c2c8ad8286776d61def222b394cab27647b7a1bf4b3915e169b65c6022cb26d5ef286f1041adfddaf8a78a2410c11424983b3580a019561eda5f2e4c3a88620f
+DIST lazy-object-proxy-1.5.0.tar.gz 35938 BLAKE2B 11e091538f4bcddd5acb39963572e30535b01227481affcb160d55b39c5b4548fef2da316efe483d6b0450e204126b957884dfb7a96727b0a00209addd6097cc SHA512 8d594df743694f01b9710e55d8e88831d6ac2e81a925ad310f0c39d061f20115550c5adf1da40d0d7c4749eb3a7ffbbb6000ebbda3dbb445c9efa1d05ff37cc3
diff --git a/dev-python/lazy-object-proxy/lazy-object-proxy-1.5.0.ebuild b/dev-python/lazy-object-proxy/lazy-object-proxy-1.5.0.ebuild
new file mode 100644
index 000000000000..763b4358bbf2
--- /dev/null
+++ b/dev-python/lazy-object-proxy/lazy-object-proxy-1.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fast and thorough lazy object proxy"
+HOMEPAGE="
+ https://github.com/ionelmc/python-lazy-object-proxy
+ https://pypi.org/project/lazy-object-proxy/
+ https://python-lazy-object-proxy.readthedocs.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # No need to benchmark
+ sed \
+ -e '/benchmark/s:test_:_&:g' \
+ -e '/pytest.mark.benchmark/d' \
+ -i tests/test_lazy_object_proxy.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -v -v --ignore=src || die "Fails for ${EPYTHON}"
+}