summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-02 20:22:43 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-02 20:51:11 +0000
commit28f4854de3779c45b3caf44679fe06c4798e6b79 (patch)
tree0b3348fe3ee7891243e718e2d42457dcd274dee1 /dev-python/line_profiler
parentsys-block/fio: Drop installation of missing file (diff)
downloadgentoo-28f4854de3779c45b3caf44679fe06c4798e6b79.tar.gz
gentoo-28f4854de3779c45b3caf44679fe06c4798e6b79.tar.bz2
gentoo-28f4854de3779c45b3caf44679fe06c4798e6b79.zip
dev-python/line_profiler: Fix python3 support
* drop old * Add pypi homepage Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest1
-rw-r--r--dev-python/line_profiler/line_profiler-1.0-r1.ebuild32
-rw-r--r--dev-python/line_profiler/line_profiler-1.0.ebuild27
-rw-r--r--dev-python/line_profiler/line_profiler-2.0.ebuild6
4 files changed, 4 insertions, 62 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index a24fecd1c241..e36d85f89317 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,2 +1 @@
-DIST line_profiler-1.0.tar.gz 65862 SHA256 a9e0c9ffa814f1215107c86c890afa8e63bec5a37d951f6f9d3668c1df2b1900 SHA512 15dd7ee10951287a5030eaff28e729e82094ec41d8e8dec803d5e44c6b9036ecbf1198365ef43c1fdd28451dec260c6491d118f1762d99fe037bb85eb7908dda WHIRLPOOL 1fd56ea4777a3c569807a124c708018fc77e68521d1f1ecdb13c343ddad3fcd881353cd71a0af36d06a12f1dd17be0f2731040fca5e827a4936298057dabf917
DIST line_profiler-2.0.tar.gz 68478 SHA256 739f8ad0e4bcd0cb82e99afc09e00a0351234f6b3f0b1f7f0090a8a2fbbf8381 SHA512 c0335fc69fb47c150fa5555af4f7fdf4b172ca12ee6512e04ba854c4a81f3e6ee5594e484d11c8ea7e9e8048e3f3b8661db52332d4ac645195a0e050acea4ecb WHIRLPOOL 6f4a3816fb22c86fe1c691a3e949be41da7680055db5c0909dbfb9af4052cfa50640eca43e0e918e903c23c9e6b8858ebff76e4fa21d8648084ade74f45a2915
diff --git a/dev-python/line_profiler/line_profiler-1.0-r1.ebuild b/dev-python/line_profiler/line_profiler-1.0-r1.ebuild
deleted file mode 100644
index 6dbe4b315ca2..000000000000
--- a/dev-python/line_profiler/line_profiler-1.0-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Line-by-line profiler"
-HOMEPAGE="https://github.com/rkern/line_profiler"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-name-from-copypasta.patch"
- "${FILESDIR}/${P}-ipython-5.0-compatibility.patch"
-)
-
-python_test() {
- "${PYTHON}" -m unittest discover -v "${S}"/tests/ \
- || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/line_profiler/line_profiler-1.0.ebuild b/dev-python/line_profiler/line_profiler-1.0.ebuild
deleted file mode 100644
index 802d85e74204..000000000000
--- a/dev-python/line_profiler/line_profiler-1.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Line-by-line profiler"
-HOMEPAGE="https://github.com/rkern/line_profiler"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- "
-
-python_test() {
- "${PYTHON}" -m unittest discover -v "${S}"/tests/ \
- || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/line_profiler/line_profiler-2.0.ebuild b/dev-python/line_profiler/line_profiler-2.0.ebuild
index 81d586184a05..48e524a993c3 100644
--- a/dev-python/line_profiler/line_profiler-2.0.ebuild
+++ b/dev-python/line_profiler/line_profiler-2.0.ebuild
@@ -3,12 +3,14 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1
DESCRIPTION="Line-by-line profiler"
-HOMEPAGE="https://github.com/rkern/line_profiler"
+HOMEPAGE="
+ https://github.com/rkern/line_profiler
+ https://pypi.python.org/pypi/line_profiler"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64"