summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-20 04:23:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-20 04:50:13 +0200
commit6582df16864bc707a1d2e801198cfb4ea5588928 (patch)
treee172d9c04bef36090efe7b8537c17394e2ef3d27 /dev-python/markdown2
parentdev-python/pbr: Bump to 5.5.1 (diff)
downloadgentoo-6582df16864bc707a1d2e801198cfb4ea5588928.tar.gz
gentoo-6582df16864bc707a1d2e801198cfb4ea5588928.tar.bz2
gentoo-6582df16864bc707a1d2e801198cfb4ea5588928.zip
dev-python/markdown2: Bump to 2.3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown2')
-rw-r--r--dev-python/markdown2/Manifest1
-rw-r--r--dev-python/markdown2/markdown2-2.3.10.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
index 270b69b6c1a1..24c69a1f8296 100644
--- a/dev-python/markdown2/Manifest
+++ b/dev-python/markdown2/Manifest
@@ -1 +1,2 @@
+DIST markdown2-2.3.10.tar.gz 102543 BLAKE2B 78c20c0b183c90d2f7e0a3e92660619761f1cd754bf3f142e5d6e29736242fb847e1ab4e4aa316378a8943912bd3a0270c0f26cfe74cf224969974ad1632cf77 SHA512 0d695cae9e131930ef67b0f389e0c14b062ddd009e441ec8b70553e4a71d7f4a0ec63f9e039624059c3fe09ad37480e3ddafcf31ffa1b031be26490c6b6b89c4
DIST markdown2-2.3.9.tar.gz 101067 BLAKE2B 4b1ba9e90e2cd370edaff4d61bec9182ca30952351274c4aa508e2e3573a79bac7ab70a1d29d279eb2a94da56a823222a9413b0f3f871f3bd2dfb2ed60621158 SHA512 1be193b27efff9bd084da94cf4121fc91cffda57165333ac644a4ad31b33da62bcda1df0fdb450a02421c0199484de5d6b65131a0afe2dd941c52a3f81bb218d
diff --git a/dev-python/markdown2/markdown2-2.3.10.ebuild b/dev-python/markdown2/markdown2-2.3.10.ebuild
new file mode 100644
index 000000000000..9ed8c1810997
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.3.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+SRC_URI="mirror://pypi/m/markdown2/${P}.tar.gz"
+HOMEPAGE="https://github.com/trentm/python-markdown2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd test || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest test_markdown2.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}