summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/mongoengine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/mongoengine')
-rw-r--r--dev-python/mongoengine/Manifest1
-rw-r--r--dev-python/mongoengine/metadata.xml8
-rw-r--r--dev-python/mongoengine/mongoengine-0.8.3.ebuild33
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mongoengine/Manifest b/dev-python/mongoengine/Manifest
new file mode 100644
index 000000000000..af4556743d4f
--- /dev/null
+++ b/dev-python/mongoengine/Manifest
@@ -0,0 +1 @@
+DIST mongoengine-0.8.3.tar.gz 219978 SHA256 e8e8acbffda03d70ab09615135b823b7707bd11a4e6c9327c2fd8cbed145c14a SHA512 b77c36ae008fb31f26a60135fbba3a9cf08375506a760daa3fe9e2558a6c67f4ea769eccf7c472c9ddef900fe50548aca00a81d0e666b007398b31cb4d32e368 WHIRLPOOL 241c0b51a2c9a130ed8416266baa1394d06def7c7b074cec7c6a35da6add251cd0aa05f0350bf9334ee9d3921e6a686c23dbdf5a3120a1459a4adfc134c244e1
diff --git a/dev-python/mongoengine/metadata.xml b/dev-python/mongoengine/metadata.xml
new file mode 100644
index 000000000000..a1b620006dcf
--- /dev/null
+++ b/dev-python/mongoengine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">MongoEngine/mongoengine</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mongoengine/mongoengine-0.8.3.ebuild b/dev-python/mongoengine/mongoengine-0.8.3.ebuild
new file mode 100644
index 000000000000..b9bfc2fe9945
--- /dev/null
+++ b/dev-python/mongoengine/mongoengine-0.8.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # connects to local DB and other nonsense
+
+DESCRIPTION="A Python Object-Document-Mapper for working with MongoDB"
+HOMEPAGE="https://github.com/MongoEngine/mongoengine/"
+SRC_URI="https://github.com/MongoEngine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pymongo[${PYTHON_USEDEP}]
+ "
+
+src_prepare() {
+ sed -i -e 's/tests/tests*/g' setup.py || die "Failed to fix test removal thingy"
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}