summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-01-05 12:19:49 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-01-05 12:22:05 -0600
commitc014735c36051107de33844b7713e4d90cbc5dc8 (patch)
treeacdf56d0a046b20b722cce53836c030133cd9f28 /dev-python/multidict/multidict-2.1.4.ebuild
parentsys-apps/openrc: 0.23.1 version bump (diff)
downloadgentoo-c014735c36051107de33844b7713e4d90cbc5dc8.tar.gz
gentoo-c014735c36051107de33844b7713e4d90cbc5dc8.tar.bz2
gentoo-c014735c36051107de33844b7713e4d90cbc5dc8.zip
dev-python/multidict: 2.1.4 version bump for #604768.
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'dev-python/multidict/multidict-2.1.4.ebuild')
-rw-r--r--dev-python/multidict/multidict-2.1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/multidict/multidict-2.1.4.ebuild b/dev-python/multidict/multidict-2.1.4.ebuild
new file mode 100644
index 000000000000..9fcbce293a08
--- /dev/null
+++ b/dev-python/multidict/multidict-2.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m pytest tests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}