summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-12 18:49:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-12 18:49:26 +0300
commit490e1c03166398fc63f736b5160d7416adb7f656 (patch)
treeb027f0ec31d51bc7b96516a4f43614493155ca3d /dev-python/munkres/munkres-1.1.4.ebuild
parentdev-python/jq: add 1.2.1, EAPI=8, enable tests (diff)
downloadgentoo-490e1c03166398fc63f736b5160d7416adb7f656.tar.gz
gentoo-490e1c03166398fc63f736b5160d7416adb7f656.tar.bz2
gentoo-490e1c03166398fc63f736b5160d7416adb7f656.zip
dev-python/munkres: add 1.1.4, EAPI=8, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/munkres/munkres-1.1.4.ebuild')
-rw-r--r--dev-python/munkres/munkres-1.1.4.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/munkres/munkres-1.1.4.ebuild b/dev-python/munkres/munkres-1.1.4.ebuild
new file mode 100644
index 000000000000..60083d981c89
--- /dev/null
+++ b/dev-python/munkres/munkres-1.1.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Module implementing munkres algorithm for the Assignment Problem"
+HOMEPAGE="https://pypi.org/project/munkres/ https://github.com/bmc/munkres"
+SRC_URI="https://github.com/bmc/munkres/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest