summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-04-26 03:00:16 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-04-26 03:00:16 +0200
commitae9f79d34c55ed9a9cb82e41d5da0f58770aefef (patch)
tree56886ba0774139b847fd750681e6708712ff03fe /dev-python/mysql-connector-python
parentdev-db/mysql-connector-c++: bump to v8.0.24 (diff)
downloadgentoo-ae9f79d34c55ed9a9cb82e41d5da0f58770aefef.tar.gz
gentoo-ae9f79d34c55ed9a9cb82e41d5da0f58770aefef.tar.bz2
gentoo-ae9f79d34c55ed9a9cb82e41d5da0f58770aefef.zip
dev-python/mysql-connector-python: bump to v8.0.24
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/mysql-connector-python')
-rw-r--r--dev-python/mysql-connector-python/Manifest1
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.24.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index 8381b5804acb..a9c79b449a0b 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1,2 +1,3 @@
DIST mysql-connector-python-8.0.22.tar.gz 12081967 BLAKE2B fc6b724ec2eb47a92294f7316093d4a4d2f4925981adeb07b305e946a047dbdaedd96c6ff9a07426fd56185f467cf6473bc84e0896d2e8fde70a188af16e9df2 SHA512 07f380922c18f9ade38f95d8e107fe8f90b8a7901fb9a36bbdfdb2b29f9cb79b0b6387a608e89bf90e9344c635d47184c750a206beacb2c9cc7615d6a7df2c29
DIST mysql-connector-python-8.0.23.tar.gz 12095843 BLAKE2B e4cc24f045d0e988ad97a9427fa3f6e20eb9d993d97f51033140e12722bc04fc3a2b252b811402daea2fea8f987948ebd8c68623f2af3e0e7e35d2b0d6fa7eda SHA512 66ca61c15573555a3f42ad8a9e9b3a4bc612c4d2b4e54928af87adcf609e131e9afd53b76c3a8da30f181e4f2111245cda5995063109526ff72f4f2062c2e528
+DIST mysql-connector-python-8.0.24.tar.gz 261660 BLAKE2B e58d587abbc41bd01a98d9d455390f78fb49b9b5dca33b9ff73e774926a8a11888e03d880121f163f75e68046800ccbb293035c377a0cb9936e4b8f19a697291 SHA512 0bfa09709e79a803c073346d0a17bee66bfd5833738f2d6b049629cb4746418446f5a290d74e56713753ca7d1b841262b6225cb85a8889457021d94c7552f034
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.24.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.24.ebuild
new file mode 100644
index 000000000000..b6e11c2c7e28
--- /dev/null
+++ b/dev-python/mysql-connector-python/mysql-connector-python-8.0.24.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client library for MariaDB/MySQL"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
+SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+
+BDEPEND=">=dev-libs/protobuf-3.6.1"
+
+RDEPEND="
+ >=dev-db/mysql-connector-c-8.0
+ >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+# tests/mysqld.py does not like MariaDB version strings.
+# See the regex MySQLServerBase._get_version.
+DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
+
+# Tests currently fail.
+# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
+RESTRICT="test"
+
+DOCS=( README.txt CHANGES.txt README.rst )
+
+python_test() {
+ "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
+}
+
+# Yeah, this is really broken, but the extension will only build this way during "install"
+python_install() {
+ distutils-r1_python_install \
+ --with-mysql-capi="${EPREFIX}/usr" \
+ --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
+ --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-protoc="${EPREFIX}/usr/bin/protoc"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples ; then
+ dodoc -r examples
+ fi
+}