summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-22 20:37:19 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-22 20:37:19 +0200
commit556c851c4ee43e86e1121f2053a6b3f015c4f418 (patch)
treeac4a062ee13c9c4f564e9e06711bf231fd47f17e /dev-python/nbdime
parentdev-python/python-docs: Remove old (diff)
downloadgentoo-556c851c4ee43e86e1121f2053a6b3f015c4f418.tar.gz
gentoo-556c851c4ee43e86e1121f2053a6b3f015c4f418.tar.bz2
gentoo-556c851c4ee43e86e1121f2053a6b3f015c4f418.zip
dev-python/nbdime: Version bump to 2.0.0
Bug: https://bugs.gentoo.org/719106 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/nbdime')
-rw-r--r--dev-python/nbdime/Manifest1
-rw-r--r--dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch36
-rw-r--r--dev-python/nbdime/nbdime-2.0.0.ebuild56
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
index 4eb4ff203327..ada1366ba877 100644
--- a/dev-python/nbdime/Manifest
+++ b/dev-python/nbdime/Manifest
@@ -1 +1,2 @@
DIST nbdime-0.2.0.tar.gz 4139079 BLAKE2B 1e6994009c8ac291272a297fe583f79123906c9e05ca2afd345c6e230e3c476259c4919e2161a049e46fa28f4490122c53d0a2bc94661683652d226a78fb39be SHA512 c156b706e1d6cc7885f987d746e91d7f0c2fa48885339fd79e778643382ab45e2e52565f45cc73b9a305c6f5177339e875f53ae46d73578443880a4c7522976d
+DIST nbdime-2.0.0.tar.gz 7768807 BLAKE2B a92ed166ae863185d06e4b3e667df4323b4cd9af9211999109186c1b559522f39ab235b710c7993515aa3c44a55ac3c4b90c424cdc28d04cc013a58add7d61cd SHA512 e68e69e37f6ece701ba8d6e59d8ee321ddaca78d9338e0c52f92b6942bfd3fbf0ec2407e9ae98cb820eb4c26509644a1770f249b815c53265dfdbffbe2b55142
diff --git a/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch b/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch
new file mode 100644
index 000000000000..ff450f2ce447
--- /dev/null
+++ b/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch
@@ -0,0 +1,36 @@
+--- a/setupbase.py
++++ b/setupbase.py
+@@ -129,17 +129,6 @@
+ build_py.finalize_options()
+
+
+-class bdist_egg_disabled(bdist_egg):
+- """Disabled version of bdist_egg
+-
+- Prevents setup.py install performing setuptools' default easy_install,
+- which it should never ever do.
+- """
+- def run(self):
+- sys.exit("Aborting implicit building of eggs. Use `pip install .` "
+- " to install from source.")
+-
+-
+ def create_cmdclass(prerelease_cmd=None, package_data_spec=None,
+ data_files_spec=None):
+ """Create a command class with the given optional prerelease class.
+@@ -179,14 +168,9 @@
+ wrapper = functools.partial(_wrap_command, wrapped)
+ handle_files = _get_file_handler(package_data_spec, data_files_spec)
+
+- if 'bdist_egg' in sys.argv:
+- egg = wrapper(bdist_egg, strict=True)
+- else:
+- egg = bdist_egg_disabled
+-
+ cmdclass = dict(
+ build_py=wrapper(build_py, strict=is_repo),
+- bdist_egg=egg,
++ bdist_egg=wrapper(bdist_egg, strict=True),
+ sdist=wrapper(sdist, strict=True),
+ handle_files=handle_files,
+ )
diff --git a/dev-python/nbdime/nbdime-2.0.0.ebuild b/dev-python/nbdime/nbdime-2.0.0.ebuild
new file mode 100644
index 000000000000..29db8fbcd28d
--- /dev/null
+++ b/dev-python/nbdime/nbdime-2.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff and merge of Jupyter Notebooks"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="webtools"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ webtools? ( net-libs/nodejs[npm] )"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs/source \
+ dev-python/recommonmark dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.0-remove-bdist_egg-hack.patch )
+
+python_configure_all() {
+ use webtools || mydistutilsargs=( --skip-npm )
+}
+
+python_test() {
+ # user.email and user.name are not configured in the sandbox
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}