summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-09-09 16:39:58 -0700
committerPatrice Clement <monsieurp@gentoo.org>2018-01-05 18:43:38 +0100
commit68df739510e810dd69036b98938c4ed55fc8b4de (patch)
tree3f10da60c89bb9ff90783743b8401d02aa12ec2f /dev-python/neovim-remote
parentapp-emulation/wine-d3d9: Test LINGUAS rather than linguas_* USE flags. (diff)
downloadgentoo-68df739510e810dd69036b98938c4ed55fc8b4de.tar.gz
gentoo-68df739510e810dd69036b98938c4ed55fc8b4de.tar.bz2
gentoo-68df739510e810dd69036b98938c4ed55fc8b4de.zip
dev-python/neovim-remote: new package.
neovim-remote is an implementation of vim's remote server controls using dev-python/neovim-python-client's msgpack rpc api and a separate `nvr` binary. If https://github.com/neovim/neovim/issues/1750 gets resolved, it won't be necessary anymore. Closes: https://bugs.gentoo.org/576814 Closes: https://github.com/gentoo/gentoo/pull/5677
Diffstat (limited to 'dev-python/neovim-remote')
-rw-r--r--dev-python/neovim-remote/Manifest1
-rw-r--r--dev-python/neovim-remote/metadata.xml12
-rw-r--r--dev-python/neovim-remote/neovim-remote-1.8.6.ebuild26
-rw-r--r--dev-python/neovim-remote/neovim-remote-9999.ebuild26
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/Manifest b/dev-python/neovim-remote/Manifest
new file mode 100644
index 000000000000..c8fb9c3ed20b
--- /dev/null
+++ b/dev-python/neovim-remote/Manifest
@@ -0,0 +1 @@
+DIST neovim-remote-1.8.6.tar.gz 434012 BLAKE2B 1fddb5e4376d3d17c2ff0c00e5f98700ab2d221af1ed1bc3f9c6dabe9cf1bdafe9f85041cb3a01f9a45f03df2d76bc0ae3c5a93603caa9ad461eb5ae50cb832f SHA512 b973b8c495a3a371b9a21ec4110beebbfe304f00d73aaf1da849df612e6ea9a08258379600ccb8d83154b8ef12e26088ba90a1668c5262b7dc9c62c844f42798
diff --git a/dev-python/neovim-remote/metadata.xml b/dev-python/neovim-remote/metadata.xml
new file mode 100644
index 000000000000..76ed9960fb57
--- /dev/null
+++ b/dev-python/neovim-remote/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lluixhi@gmail.com</email>
+ <name>Aric Belsito</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/neovim-remote/neovim-remote-1.8.6.ebuild b/dev-python/neovim-remote/neovim-remote-1.8.6.ebuild
new file mode 100644
index 000000000000..a6aa978b3b88
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-1.8.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/neovim-remote/neovim-remote-9999.ebuild b/dev-python/neovim-remote/neovim-remote-9999.ebuild
new file mode 100644
index 000000000000..a6aa978b3b88
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"