summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-25 21:34:48 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-25 21:40:18 +0100
commit2b850c4269f0e34b7965e0276c0a80061607dd43 (patch)
tree61c2005ef879d0289c135c4d2a6540f1e9748772 /dev-python/nest_asyncio
parentdev-python/virtualenv: Bump to 20.1.0 (diff)
downloadgentoo-2b850c4269f0e34b7965e0276c0a80061607dd43.tar.gz
gentoo-2b850c4269f0e34b7965e0276c0a80061607dd43.tar.bz2
gentoo-2b850c4269f0e34b7965e0276c0a80061607dd43.zip
dev-python/nest_asyncio: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nest_asyncio')
-rw-r--r--dev-python/nest_asyncio/Manifest1
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/nest_asyncio/Manifest b/dev-python/nest_asyncio/Manifest
index 78d038457a4b..92f7ca6a9c02 100644
--- a/dev-python/nest_asyncio/Manifest
+++ b/dev-python/nest_asyncio/Manifest
@@ -1 +1,2 @@
DIST nest_asyncio-1.4.0.tar.gz 7053 BLAKE2B e9bdfa53f8a94ddbfd87b638962b5281aa3e8830c75a019d66d8275eb107aa7268d7f5aa24782d648a5fcfbfc4e1040abf2f2f0ca5678a513a95111d293eb055 SHA512 6a5130938baabafba30c4d5435276d33aa5df5e52a84e5646de55ab64bc01d3b69340b725b74dbe3dd158d5fba8db1470a322bdcdc3b75aa1a121076e3553a06
+DIST nest_asyncio-1.4.2.tar.gz 5991 BLAKE2B 8a7feba9d506002ffa6658188fc1a20e2ac55f6661c2be37be678c6930e906235cdd94b5e359428555d8b9400a810a3483e07b3118b49757464fb9e8195a4cdf SHA512 00581b5dbecd085f2f4534dceb04b894973939c6e209bfae1f4b13b5c608bcf403f590af9694c6973e06dc325a5c7b8dc278f8b83eb5ca125a96074e0046984e
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild
new file mode 100644
index 000000000000..59e0ec644321
--- /dev/null
+++ b/dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests setup.py