summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 10:10:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 10:10:58 +0100
commite183b5e961e3f607177190e06d948b56a433d6f4 (patch)
treef7255a175851e966c1e6848eddd0ac6cba11dd00 /dev-python/nnpy
parentdev-python/nltk: Remove redundant versions (diff)
downloadgentoo-e183b5e961e3f607177190e06d948b56a433d6f4.tar.gz
gentoo-e183b5e961e3f607177190e06d948b56a433d6f4.tar.bz2
gentoo-e183b5e961e3f607177190e06d948b56a433d6f4.zip
dev-python/nnpy: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nnpy')
-rw-r--r--dev-python/nnpy/Manifest1
-rw-r--r--dev-python/nnpy/files/py3.patch19
-rw-r--r--dev-python/nnpy/nnpy-1.4.1.ebuild29
3 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/nnpy/Manifest b/dev-python/nnpy/Manifest
index 26c6d13e2103..8d130691ad33 100644
--- a/dev-python/nnpy/Manifest
+++ b/dev-python/nnpy/Manifest
@@ -1,2 +1 @@
-DIST nnpy-1.4.1.tar.gz 4826 BLAKE2B 28e976fdde6580e5f0e828f4e68858ca74459899092b448f0f54f89d88cb1dc7e9df9583de76d2e9ee824909c834404cfca92d0a477bfa58573c57e9ddac0cda SHA512 26e1393fdca77cc9385eff0622f9a5b4987eeca533c57478ba873a1ea96f312a2d535fd3eaa883c47746157a9d692b4b0f6c52d51ea5b4fea5fb885cfdadc2a2
DIST nnpy-1.4.2.tar.gz 4830 BLAKE2B 7e1e3d3ade400e96e43504e490f22e5595850d54e80d4591fa0a519a47a492aaf569d9937c4ee05fc9504c4beb5cb2ef8496a65874e64b6162087eade6762906 SHA512 b0908e3b53ac62d8a41ecadd412b2c4bff69773d5eeecc2eb72cad2667c3a14405dc1dfa6f2cdf4f81cf76b9eadbcdca5bdfa1499a2f0c3beddbacbd3e21b7d7
diff --git a/dev-python/nnpy/files/py3.patch b/dev-python/nnpy/files/py3.patch
deleted file mode 100644
index 8a39044bb7f1..000000000000
--- a/dev-python/nnpy/files/py3.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 98ee46a4034ca94d6123b854e79f1dc3f35fff4a
-Author: Alexis Ballier <aballier@gentoo.org>
-Date: Sat Jun 3 19:55:10 2017 +0200
-
- Fix tests under python3.
-
-diff --git a/nnpy/tests.py b/nnpy/tests.py
-index ba2a3fe..7f9f6e0 100644
---- a/nnpy/tests.py
-+++ b/nnpy/tests.py
-@@ -17,7 +17,7 @@ class Tests(unittest.TestCase):
- poller = nnpy.PollSet((sub, nnpy.POLLIN))
- self.assertEqual(len(poller.poll()), 1)
- self.assertEqual(poller.poll()[0], 1)
-- self.assertEqual(sub.recv(), 'FLUB')
-+ self.assertEqual(sub.recv().decode(), 'FLUB')
- self.assertEqual(pub.get_statistic(nnpy.STAT_MESSAGES_SENT), 1)
- pub.close()
- sub.shutdown(sub_conn)
diff --git a/dev-python/nnpy/nnpy-1.4.1.ebuild b/dev-python/nnpy/nnpy-1.4.1.ebuild
deleted file mode 100644
index b359e5c9c2f6..000000000000
--- a/dev-python/nnpy/nnpy-1.4.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="cffi-based Python bindings for nanomsg"
-HOMEPAGE="https://github.com/nanomsg/nnpy"
-SRC_URI="https://github.com/nanomsg/nnpy/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm"
-IUSE=""
-
-DEPEND="
- dev-python/cffi:=[${PYTHON_USEDEP}]
- dev-libs/nanomsg:=
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/py3.patch" )
-
-python_test() {
- PYTHONPATH="${S}:${PYTHONPATH}" "${PYTHON}" "${S}/nnpy/tests.py" || die
-}