summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-19 17:11:52 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-19 18:29:11 +0200
commit7f3f531753c50c9dea30b7b74c79112d1bb07a68 (patch)
tree26b19c45d95e72bdad2bae20ef3638dc1275120b /dev-python/numpydoc
parentdev-python/xlwt: Add python3.5 support (diff)
downloadgentoo-7f3f531753c50c9dea30b7b74c79112d1bb07a68.tar.gz
gentoo-7f3f531753c50c9dea30b7b74c79112d1bb07a68.tar.bz2
gentoo-7f3f531753c50c9dea30b7b74c79112d1bb07a68.zip
dev-python/numpydoc: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/numpydoc')
-rw-r--r--dev-python/numpydoc/numpydoc-0.5.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/numpydoc/numpydoc-0.5.ebuild b/dev-python/numpydoc/numpydoc-0.5.ebuild
index 69b9e0e016e5..81bf9036a9c5 100644
--- a/dev-python/numpydoc/numpydoc-0.5.ebuild
+++ b/dev-python/numpydoc/numpydoc-0.5.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1 vcs-snapshot
@@ -16,11 +17,14 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="test"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
+DEPEND="
+ test? ( ${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-1.4.0[${PYTHON_USEDEP}] )"
+ >=dev-python/matplotlib-1.4.0[${PYTHON_USEDEP}]
+ )"
python_prepare_all() {
chmod -R a+r *.egg-info || die
@@ -28,5 +32,5 @@ python_prepare_all() {
}
python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
+ nosetests --verbose || die "Testing failed with ${EPYTHON}"
}