summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-22 19:29:27 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-22 19:29:27 +0200
commit907d0c10da7cf223779a541240b950d7a1efd25f (patch)
tree66ff2ee2a05754fb3f8b4f360c427dcc86043a77 /dev-python/oct2py/oct2py-3.6.0.ebuild
parentdev-python/oct2py: Version bump to 5.2.0 (diff)
downloadgentoo-907d0c10da7cf223779a541240b950d7a1efd25f.tar.gz
gentoo-907d0c10da7cf223779a541240b950d7a1efd25f.tar.bz2
gentoo-907d0c10da7cf223779a541240b950d7a1efd25f.zip
dev-python/oct2py: Remove old 3.6.0, 4.0.6
Closes: https://bugs.gentoo.org/726346 Closes: https://bugs.gentoo.org/731458 Closes: https://bugs.gentoo.org/732946 Closes: https://bugs.gentoo.org/737368 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/oct2py/oct2py-3.6.0.ebuild')
-rw-r--r--dev-python/oct2py/oct2py-3.6.0.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/oct2py/oct2py-3.6.0.ebuild b/dev-python/oct2py/oct2py-3.6.0.ebuild
deleted file mode 100644
index 7439762cf917..000000000000
--- a/dev-python/oct2py/oct2py-3.6.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python to GNU Octave bridge"
-HOMEPAGE="
- https://github.com/blink1073/oct2py
- https://blink1073.github.io/oct2py/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
- >=sci-libs/scipy-0.12[${PYTHON_USEDEP}]
- >=sci-mathematics/octave-4.2.0"
-DEPEND="${RDEPEND}
- doc? (
- dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # https://github.com/blink1073/oct2py/issues/77
- sed \
- -e 's:test_help:disabled:g' \
- -i oct2py/tests/test_usage.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs html || die
- fi
-}
-
-python_test() {
- unset DISPLAY
- [[ ${EPYTHON} == python2.7 ]] && local OPTIONS="--with-doctest"
- nosetests --exe -v oct2py ${OPTIONS} || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( html/. )
- if use examples; then
- docinto examples
- dodoc -r example/.
- fi
-
- distutils-r1_python_install_all
-}