summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-10 18:40:58 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-10 18:43:07 -0400
commit29971ff31ac9b960ae1aaae45c0e665484c2d0a0 (patch)
treee4ef4fa6fe485e9eb158540cef15ab9260f42562 /dev-python/openpyxl
parentnet-misc/owncloud-client: 2.4.2 bump (diff)
downloadgentoo-29971ff31ac9b960ae1aaae45c0e665484c2d0a0.tar.gz
gentoo-29971ff31ac9b960ae1aaae45c0e665484c2d0a0.tar.bz2
gentoo-29971ff31ac9b960ae1aaae45c0e665484c2d0a0.zip
Revert "dev-python/openpyxl: remove old and vulnerable"
This reverts commit faa0d1e93590c9a89b98f7be63db9c9017c6b765. It broke QA du to old pyhon usedep on revdeps not being available anymore. It's the second time I get bitten by this...
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/Manifest2
-rw-r--r--dev-python/openpyxl/openpyxl-2.3.0.ebuild35
-rw-r--r--dev-python/openpyxl/openpyxl-2.3.3.ebuild35
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/openpyxl/Manifest b/dev-python/openpyxl/Manifest
index 14b753e669cf..151774e88b3a 100644
--- a/dev-python/openpyxl/Manifest
+++ b/dev-python/openpyxl/Manifest
@@ -1 +1,3 @@
+DIST openpyxl-2.3.0.tar.gz 138746 BLAKE2B 74a6ebcee9f7c235a4e590de18b39fe04eccf4e37caad64f727a19317b302649821b2ce42bd4ae8d2f192e6cfbe284b2b07b452f28ec4c52850ad32de3c9025b SHA512 e0d438c753628618748af7511366936681e63046fdb9dfb8509db8701194dc2875394892392e6871a367a68c08b730efdac29a88db6b0589fd619066145fff9f
+DIST openpyxl-2.3.3.tar.gz 141530 BLAKE2B 5efb845e8a208a8214380c8766db0c448a59dc5976b23ab8ca8d88481390ac6fdb250a629389eff7f2072566ff640ad15b5d5969218b49f0fe44a2da806e1682 SHA512 b5fb65acb711affe40e466c91d58a8dc989ada06cc58cee046311b6e65073e49ebddac8912f1b5642eb2be36ed8ff4f9a8b07acd75cdd067807fa8898b47c065
DIST openpyxl-2.4.11.tar.bz2 2139621 BLAKE2B 44fe7e471b50deabdea10e677e3b30f2eee62c661203517321e32442639e884c93ff3c4b6e7a0e5c5186bc8320c53d912832d955882b8cdb29c81d8319077c7c SHA512 9d1f9a3cadefec42bd7b6301bc3a37045e59e567a9f74eed3467547e81f060cf1c0ce2fc7f517911cd7f5716a42135a8567a0e0edc42eae0cc0c7a2370b320ae
diff --git a/dev-python/openpyxl/openpyxl-2.3.0.ebuild b/dev-python/openpyxl/openpyxl-2.3.0.ebuild
new file mode 100644
index 000000000000..999223550caf
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-2.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+# tests aren't contained in tarball
+RESTRICT="test"
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/openpyxl/openpyxl-2.3.3.ebuild b/dev-python/openpyxl/openpyxl-2.3.3.ebuild
new file mode 100644
index 000000000000..8de94aaf934c
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-2.3.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+# tests aren't contained in tarball
+RESTRICT="test"
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}