summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-16 15:14:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-16 16:21:16 -0500
commit3ae36b0ecc644dd60d098555012607811dcdf130 (patch)
tree0b59bcfd8d639b8245e7507559bce3dc28f4428a /dev-python/os-traits
parentsys-cluster/neutron: 16.0.0 ussuri bump (diff)
downloadgentoo-3ae36b0ecc644dd60d098555012607811dcdf130.tar.gz
gentoo-3ae36b0ecc644dd60d098555012607811dcdf130.tar.bz2
gentoo-3ae36b0ecc644dd60d098555012607811dcdf130.zip
dev-python/os-traits: 2.3.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/os-traits')
-rw-r--r--dev-python/os-traits/Manifest1
-rw-r--r--dev-python/os-traits/os-traits-2.3.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/os-traits/Manifest b/dev-python/os-traits/Manifest
index 3d8e65601baf..20add1a9c55b 100644
--- a/dev-python/os-traits/Manifest
+++ b/dev-python/os-traits/Manifest
@@ -1 +1,2 @@
DIST os-traits-0.16.0.tar.gz 24583 BLAKE2B 8f81c4ae3cd88f74b7b44033800af4475c2e76cf4ca402504bb54444c3952fa97a2871336bcdd4a5ed870e423c1201fe0ca658d663d19286098641efd88bc060 SHA512 93ff4c066e0819cacf3a8cc8b80b05960e7a4b7c31af1d249f61f95eac1f37ea21f0f1ddb6e6dbc5b9c023394e10db88a105bbfbbfaf10afc57078040838a8f7
+DIST os-traits-2.3.0.tar.gz 25968 BLAKE2B 9c749ca63f7d67e979a732fbc5de3285ec2635a6ca92fae26f8801e9d9f3dcd1a09b3eacb10162a5e53be932ddc48a8f379a17c8cfb3dbe6114339c35d943111 SHA512 0dd7379dded33a89e1163fb929cc50016474912817f99f048abf325cedd9369d155cf8ecfdcd868ec1bf124c0a44f9926daeffa68877bf723f78a15f6c091e90
diff --git a/dev-python/os-traits/os-traits-2.3.0.ebuild b/dev-python/os-traits/os-traits-2.3.0.ebuild
new file mode 100644
index 000000000000..57385c932b61
--- /dev/null
+++ b/dev-python/os-traits/os-traits-2.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="os-traits is a library containing standardized trait strings."
+HOMEPAGE="https://github.com/openstack/os-traits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}