summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-16 05:00:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-16 05:00:08 +0200
commit0d94fa67c2d366be005ca2f3e9508de6d0157d7c (patch)
treefeaf1dd34a9c4bf0c86676671d5fa3510f626e62 /dev-python/pecan
parentdev-python/dnspython: Bump to 2.4.0 (diff)
downloadgentoo-0d94fa67c2d366be005ca2f3e9508de6d0157d7c.tar.gz
gentoo-0d94fa67c2d366be005ca2f3e9508de6d0157d7c.tar.bz2
gentoo-0d94fa67c2d366be005ca2f3e9508de6d0157d7c.zip
dev-python/pecan: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pecan')
-rw-r--r--dev-python/pecan/Manifest1
-rw-r--r--dev-python/pecan/pecan-1.5.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pecan/Manifest b/dev-python/pecan/Manifest
index 279cac787977..5461f3d587d1 100644
--- a/dev-python/pecan/Manifest
+++ b/dev-python/pecan/Manifest
@@ -1,2 +1,3 @@
DIST pecan-1.4.2.tar.gz 124900 BLAKE2B bf78c630605dbf020bcda830855cf19dc660c8bdbfa6d68a9739a0da7c585ec17d30525d37337867e007aa31d3329e87224cfd4e0335b14496df911457af5c82 SHA512 cea290db5b7c4664057ec326e1f9ac11d4b523e2df83a84c3b47acbce0520f248bbd33de0f66379409a4ff463b6408b587238917362572479288d36843542ab0
DIST pecan-1.5.0.tar.gz 124111 BLAKE2B 2a72c891300f847f463b3f9a8738113929a12f256ba9a7c7b2ece23f807e56ea36376fe8a28ba57c2e67f82e1d6cd9f754b2680a27cad0910a5f1005a4e9dec2 SHA512 c48082aa0841b58ead990011901cbc43c9fa9ffc586321f47eca8ea51d80fd4a05fbf8ea85459362a7419f5eadd15b3ca89eaad9e69b754aff5c44b46e06552e
+DIST pecan-1.5.1.tar.gz 124161 BLAKE2B 441c4fcc94409aef93324ab8dfb727fc09a3e0f8802ba804d3d5f52237d4f089c3eed23f55a8ad82a9d372d28d622faf8b196b59936e7fc9feb69c4f87883084 SHA512 87fff8657268accda3a53f156338332e3d23df8055cc62d77d9f1641f692c1d7e4013f564b0108541e5df69e1d3d2c8e3df87486e0b4316e437f67d010013fa9
diff --git a/dev-python/pecan/pecan-1.5.1.ebuild b/dev-python/pecan/pecan-1.5.1.ebuild
new file mode 100644
index 000000000000..8ab7bc4d01ce
--- /dev/null
+++ b/dev-python/pecan/pecan-1.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies"
+HOMEPAGE="
+ https://github.com/pecan/pecan/
+ https://pypi.org/project/pecan/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest