summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-16 15:55:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-16 15:55:55 +0100
commit99b614f39d357f21b1cc92407ee11affcc3e0d67 (patch)
treeb990b5d9bc6869ffb3f3365b66d4458cc9f413d8 /dev-python/prometheus_client
parentdev-lang/lua: 5.4.1 bump (diff)
downloadgentoo-99b614f39d357f21b1cc92407ee11affcc3e0d67.tar.gz
gentoo-99b614f39d357f21b1cc92407ee11affcc3e0d67.tar.bz2
gentoo-99b614f39d357f21b1cc92407ee11affcc3e0d67.zip
dev-python/prometheus_client: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.9.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index 05b2f9b7eff2..4da206b11771 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1 +1,2 @@
DIST prometheus_client-0.8.0.tar.gz 67749 BLAKE2B 570c95de0d4e9e8bd625d55eb3dd450cf933ab7c8b6af74ff56414045f4d845c4a74f60d60e8b29f868801de12ebe2d39b5ac11701071c4998aec66719581b3f SHA512 a9d49bc4dac77168f94edf51344042bc5210b07ed01031dc50e323f86ea8292df7370956a4fbd9d9f85a0857a8ec9abaef30c0c2cd4dc5502df7264816eecc8f
+DIST prometheus_client-0.9.0.tar.gz 68176 BLAKE2B e20f599e6a4d39226e48cafeca879b87389fdb5a6eda401161ce448cb0b46a89ce0cccc1b78e2fc8cb60cc461253345b9ba52809c861f0a187171c33095f625a SHA512 1d68ca35169972c50bb56ede88c47408ee27b3e795fcf03798313aed2dbc5db5532fe6886998c118258b76e431c6e49aa0ac19b9206cad63711901497258aaa5
diff --git a/dev-python/prometheus_client/prometheus_client-0.9.0.ebuild b/dev-python/prometheus_client/prometheus_client-0.9.0.ebuild
new file mode 100644
index 000000000000..173bdca64c55
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.9.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.org/project/prometheus_client/
+ https://github.com/prometheus/client_python"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/client_python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/twisted[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest