summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-11-22 03:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-11-22 14:31:56 -0500
commitedebaa855eba8aad1429c48b7e3e8ee46d091114 (patch)
tree8939283c07616463fdce2d843163f50e395b30e7 /dev-python/protobuf-python/protobuf-python-9999.ebuild
parentdev-python/protobuf-python: Update subslot. (diff)
downloadgentoo-edebaa855eba8aad1429c48b7e3e8ee46d091114.tar.gz
gentoo-edebaa855eba8aad1429c48b7e3e8ee46d091114.tar.bz2
gentoo-edebaa855eba8aad1429c48b7e3e8ee46d091114.zip
dev-python/protobuf-python: Update dependencies.
https://github.com/protocolbuffers/protobuf/commit/3abbbd8870054a89c7c3d1005f49eead83c87ded https://github.com/protocolbuffers/protobuf/commit/7daf0aa7b00261bc8e0a433c58e74083cd58ea43 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/protobuf-python/protobuf-python-9999.ebuild')
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
index 8deb3225f653..cf83c9cb0fbd 100644
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
-DISTUTILS_USE_SETUPTOOLS="rdepend"
+DISTUTILS_USE_SETUPTOOLS="bdepend"
inherit distutils-r1
@@ -49,19 +49,12 @@ python_prepare_all() {
popd > /dev/null || die
distutils-r1_python_prepare_all
-
- sed -e "/^[[:space:]]*setup_requires = \['wheel'\],$/d" -i setup.py || die
}
python_configure_all() {
mydistutilsargs=(--cpp_implementation)
}
-python_compile() {
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
python_test() {
esetup.py test
}