summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-01 19:43:14 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-02 12:47:12 +0100
commit48f83e7878a062e4ec0b665a2a1b958205b68205 (patch)
treeadacf61327e0a10e9ed403740eabf4558d41fed0 /dev-python/py/py-1.4.27.ebuild
parentdev-python/pytest-runner: Keyword under ALLARCHES policy (diff)
downloadgentoo-48f83e7878a062e4ec0b665a2a1b958205b68205.tar.gz
gentoo-48f83e7878a062e4ec0b665a2a1b958205b68205.tar.bz2
gentoo-48f83e7878a062e4ec0b665a2a1b958205b68205.zip
dev-python/py: Drop old
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/py/py-1.4.27.ebuild')
-rw-r--r--dev-python/py/py-1.4.27.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/py/py-1.4.27.ebuild b/dev-python/py/py-1.4.27.ebuild
deleted file mode 100644
index 4d184df25266..000000000000
--- a/dev-python/py/py-1.4.27.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
-HOMEPAGE="http://pylib.readthedocs.org/ https://pypi.python.org/pypi/py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -e 's:intersphinx_mapping:#&:' -i doc/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- # 1 failure, test_comments, under both pypy only.
- # Also appears the home repo has no issue tracker.
- py.test || die "testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}