summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-16 10:14:15 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-16 10:49:15 +0300
commit65db49f158d6f4c4e77f5d33d01baa30f876e9c5 (patch)
tree9f5b424675e338177ddd99b5881d8273c3a58b55 /dev-python/pyatspi
parentprofiles/package.mask: mask old ruby slots for removal (diff)
downloadgentoo-65db49f158d6f4c4e77f5d33d01baa30f876e9c5.tar.gz
gentoo-65db49f158d6f4c4e77f5d33d01baa30f876e9c5.tar.bz2
gentoo-65db49f158d6f4c4e77f5d33d01baa30f876e9c5.zip
dev-python/pyatspi: enable py3.8, tests
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/pyatspi-2.36.0.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/pyatspi/pyatspi-2.36.0.ebuild b/dev-python/pyatspi/pyatspi-2.36.0.ebuild
index 3c1b5335abf1..3e2dd64de8ae 100644
--- a/dev-python/pyatspi/pyatspi-2.36.0.ebuild
+++ b/dev-python/pyatspi/pyatspi-2.36.0.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
-inherit gnome2 python-r1
+inherit gnome2 python-r1 virtualx
DESCRIPTION="Python client bindings for D-Bus AT-SPI"
HOMEPAGE="https://wiki.gnome.org/Accessibility"
@@ -14,7 +14,7 @@ LICENSE="LGPL-2 GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="" # test
+IUSE="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
COMMON_DEPEND="${PYTHON_DEPS}
@@ -29,6 +29,7 @@ RDEPEND="${COMMON_DEPEND}
"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
+ test? ( sys-apps/dbus )
"
src_prepare() {
@@ -37,13 +38,17 @@ src_prepare() {
}
src_configure() {
- python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
+ python_foreach_impl run_in_build_dir gnome2_src_configure $(use_enable test tests)
}
src_compile() {
python_foreach_impl run_in_build_dir gnome2_src_compile
}
+src_test() {
+ python_foreach_impl run_in_build_dir virtx dbus-run-session emake check
+}
+
src_install() {
installing() {
gnome2_src_install