summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-21 19:05:21 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-21 20:53:52 +0200
commit69caafe0910c273534d6d96789ca564461ac1604 (patch)
treedb1f5b89a38661427775831385107fc746b57be3 /dev-python/pybind11
parentdev-python/pygame: Bump to 2.0.0dev18 (diff)
downloadgentoo-69caafe0910c273534d6d96789ca564461ac1604.tar.gz
gentoo-69caafe0910c273534d6d96789ca564461ac1604.tar.bz2
gentoo-69caafe0910c273534d6d96789ca564461ac1604.zip
dev-python/pybind11: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest1
-rw-r--r--dev-python/pybind11/pybind11-2.6.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 6b89938f6dcc..c7cab97756cf 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1 +1,2 @@
DIST pybind11-2.5.0.tar.gz 573769 BLAKE2B e46d99f873f8266efc577d3e0ab1e8a78784a45c35995bc3486501d627698e0fb10205008e8cb82c84e971f20cd02a6d2f08390f3a3041fff1a21c45f11b197f SHA512 7f3a9c71916749436898d1844ef6b112baf0817a386308b5df8dec2a912ef4b6a932b94965e98f227c49fa77312f131972a6039f23b84a3daf6442a8ab0be7c2
+DIST pybind11-2.6.0.tar.gz 631925 BLAKE2B 6b7872182f52e035f2a86f0f2ad70b084e62fc20d5aae4903c13ff824f80f3815845f3206d740d17ae471fd979eca117d9d4ee011f9f96c319ca808e6304b07f SHA512 6a3f407c136d827243c0043c794c654ca267a1a4e3b7e0e45cc7629e29193156b0744d85e45222fab284a9af82cf7fa2008fbd977d2b5a7b947c8a6581456caf
diff --git a/dev-python/pybind11/pybind11-2.6.0.ebuild b/dev-python/pybind11/pybind11-2.6.0.ebuild
new file mode 100644
index 000000000000..ad41df44bfd7
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.6.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pybind11.readthedocs.io/en/stable/"
+SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+
+distutils_enable_sphinx docs \
+ '<dev-python/sphinx-3' \
+ dev-python/breathe \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+
+ # broken with scipy-1.4.1
+ sed -i -e 's:test_sparse:_&:' tests/test_eigen.py || die
+
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}