summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-24 14:42:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-24 18:13:31 +0100
commitc888924d75f28b310dd19c823e14526a574d2579 (patch)
tree881e202d97f9359cead8c69261ea78c60f6becf4 /dev-python/pycountry
parentmedia-libs/libheif: 1.6.0 version bump (diff)
downloadgentoo-c888924d75f28b310dd19c823e14526a574d2579.tar.gz
gentoo-c888924d75f28b310dd19c823e14526a574d2579.tar.bz2
gentoo-c888924d75f28b310dd19c823e14526a574d2579.zip
dev-python/pycountry: 19.8.18 version bump, EAPI-7 bump, python3_8
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pycountry')
-rw-r--r--dev-python/pycountry/Manifest1
-rw-r--r--dev-python/pycountry/pycountry-19.8.18.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pycountry/Manifest b/dev-python/pycountry/Manifest
index 12c2615a330d..f041911523cb 100644
--- a/dev-python/pycountry/Manifest
+++ b/dev-python/pycountry/Manifest
@@ -1,3 +1,4 @@
DIST pycountry-16.11.8.tar.gz 9042735 BLAKE2B 66f5dcb0b9b55be692e398c998babeb49542cb5383a706bb74091088eaa3703f41da33f59e2267046c53f8f025f85945096d1e8d251ad5af57c5d39a27896cf2 SHA512 eb0a91f1efae6aeace0b49cd44b0770efa0b57add208c4247e7f58a3c46774f9f8007c51ee88a0e108c90ced3ad69204b4322c9c23f51df0b2202aa98c314a37
DIST pycountry-17.9.23.tar.gz 9208478 BLAKE2B 381497b220991f76bdac235b71fd9c10984f5762e9cc16b813cb37cfef0444bbaada01e1ed9513848c681a06335ff58544f6f7c2217b51ef98c7415db4b3d285 SHA512 168e2d2693629a39a85a4c6aa7187323693ca73d6af0cc947d3536ae373eca602e7e3add91ba114966db4ebf52118ef3d6a3dbf8339734ec68682bab559beeb5
DIST pycountry-18.5.26.tar.gz 9779056 BLAKE2B 11928f29cb7446db7159936619a5d0828af89ec7a2ca355d809c97887605174e41d3f93d7e459f3f37ce37b9a7650432df1e7619f9fdfa1f9ea010a39af4501a SHA512 9760175a7926347920542a2fd2420cc3d4f36ac11df5aa6f7aaabbd9b46dd9cb61801933133a589ed35fd2e279db2a70e98340d8cf8856987dc88d6fdb715437
+DIST pycountry-19.8.18.tar.gz 10003160 BLAKE2B ac7894e9fc1ed4e8f386cc6e07c1fc2abefee63c39c7c851c100519418606b52bc18be8da672930ceefdc7ca7b51571e4b3884ea0c20e547e5b596e249ebf407 SHA512 39ba06629eeea55460424d06992ca5f1e5bf6168b219dc4880ec326f6aa0c92a4fdc54d4143a8b8bb1490149af793e760e291c6d704104a57ba91e88228ab669
diff --git a/dev-python/pycountry/pycountry-19.8.18.ebuild b/dev-python/pycountry/pycountry-19.8.18.ebuild
new file mode 100644
index 000000000000..99429b4ab6c9
--- /dev/null
+++ b/dev-python/pycountry/pycountry-19.8.18.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://bitbucket.org/flyingcircus/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null || die
+ if [[ ${EPYTHON} == pypy* ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ pytest -vv || die
+ popd > /dev/null || die
+}