summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-03 11:20:44 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-03 11:24:40 +0100
commit246d064f055d1e145fd029074f7602b711255460 (patch)
tree575672a0a842422b8486bbc4405b38070dc36e43 /dev-python/pycrypto
parentdev-python/pycurl: Verison Bump (diff)
downloadgentoo-246d064f055d1e145fd029074f7602b711255460.tar.gz
gentoo-246d064f055d1e145fd029074f7602b711255460.tar.bz2
gentoo-246d064f055d1e145fd029074f7602b711255460.zip
dev-python/pycrypto: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pycrypto')
-rw-r--r--dev-python/pycrypto/pycrypto-2.6.1-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pycrypto/pycrypto-2.6.1-r1.ebuild b/dev-python/pycrypto/pycrypto-2.6.1-r1.ebuild
index 6facd378531b..8bfd1a2a3935 100644
--- a/dev-python/pycrypto/pycrypto-2.6.1-r1.ebuild
+++ b/dev-python/pycrypto/pycrypto-2.6.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
@@ -27,7 +27,7 @@ DEPEND="${RDEPEND}
REQUIRED_USE="test? ( gmp )"
python_prepare_all() {
- epatch "${FILESDIR}"/${P}-cross-compile.patch
+ local PATCHES=( "${FILESDIR}"/${P}-cross-compile.patch )
# Fix Crypto.PublicKey.RSA._RSAobj.exportKey(format="OpenSSH") with Python 3
# https://github.com/dlitz/pycrypto/commit/ab25c6fe95ee92fac3187dcd90e0560ccacb084a
sed \
@@ -48,7 +48,7 @@ python_configure_all() {
python_compile_all() {
if use doc; then
- rst2html.py Doc/pycrypt.rst > Doc/index.html
+ rst2html.py Doc/pycrypt.rst > Doc/index.html || die
epydoc --config=Doc/epydoc-config --exclude-introspect="^Crypto\.(Random\.OSRNG\.nt|Util\.winrandom)$" || die
fi
}