summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-21 22:29:28 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-21 22:48:14 +0200
commitfef4db8b17a9aa1611d1624ff90dcf9c5f461887 (patch)
tree9280ec93ae818fc19a29e40945f3a136cb305147 /dev-python/pyghmi
parentdev-python/PyPDF2: Bump to 1.27.8 (diff)
downloadgentoo-fef4db8b17a9aa1611d1624ff90dcf9c5f461887.tar.gz
gentoo-fef4db8b17a9aa1611d1624ff90dcf9c5f461887.tar.bz2
gentoo-fef4db8b17a9aa1611d1624ff90dcf9c5f461887.zip
dev-python/pyghmi: Bump to 1.5.39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.39.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 8be9b51d4886..5bf741887a78 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1,3 +1,4 @@
DIST pyghmi-1.5.36.tar.gz 240917 BLAKE2B 69e7f990c97a889d90e06feeb1b7b3fc73d6441cfe8ba7a22e0aa0e2b3553afb5166fb732699718dad04592aca95b8aaf28943ed92de136e45f381094b7c97af SHA512 b5536cf1c48929cb8acc7c9f77c09d0d51456cdfb2f74346387a483661332cdc02a614eac633a3e9aeabfac48b1a25a627668660be167fbf07b96c090ac6e197
DIST pyghmi-1.5.37.tar.gz 241173 BLAKE2B 7094150c6002b59e1fcd9b337987d3506928222d55195c024027d31d281e5074210dac91c64853bbaac628dc112b9c4081a7193146927112dcc987f789faa018 SHA512 e70894f6e63afadc68bae88ebd8ff1f63904106db86b582b547a6f1eb7acde903352f08ffc62d7915e2baa45507f70331a6dc9f6b0dcd471fd330e39a69d064f
DIST pyghmi-1.5.38.tar.gz 241170 BLAKE2B f056fb985ca1281fc481bf9ccaa5a6c86a05655fa6d3055e4ef2d9823e2893fff7ce795aebca5fafca5a368836372a71c73b6d8210b458f1dc54e9b68e429d4c SHA512 8d134cf2fa4c1226debe383832141e36f77a465acf02b2fcdf1ba5b621bf23444f40c69b9ce98c0ad096a8f2e5e9b04b4d0627d25354b76a130bece8d75f91c8
+DIST pyghmi-1.5.39.tar.gz 241157 BLAKE2B f406ad0dd6ae2b45c34aae14738f10c86f0a62082f7da2ab75b8e01558a9c0a8aa4c123cca935a0f3f03f5ae92d799d283dd81155d3c31c886555184f69be2b7 SHA512 efbc603002870edbeb4944207521077f5c25ed080578d3008a542a0e65d3769fe1da7105ed15d85acc3931a126a440e64b6ff9d88f6f4a3b66a5cdabcbab3e4c
diff --git a/dev-python/pyghmi/pyghmi-1.5.39.ebuild b/dev-python/pyghmi/pyghmi-1.5.39.ebuild
new file mode 100644
index 000000000000..1844c945d4be
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.39.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest