summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 22:17:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 22:18:42 +0200
commit4ff1660d67a617c8215ba6f4b39accebe753e476 (patch)
treeafb697835f4f05204e3ea0c90a66c730388dd924 /dev-python/pyinotify
parentdev-python/numpydoc: Port to py3.9 (diff)
downloadgentoo-4ff1660d67a617c8215ba6f4b39accebe753e476.tar.gz
gentoo-4ff1660d67a617c8215ba6f4b39accebe753e476.tar.bz2
gentoo-4ff1660d67a617c8215ba6f4b39accebe753e476.zip
dev-python/pyinotify: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyinotify')
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.6.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pyinotify/pyinotify-0.9.6.ebuild b/dev-python/pyinotify/pyinotify-0.9.6.ebuild
index 765b6630ae65..5221c9f20f1f 100644
--- a/dev-python/pyinotify/pyinotify-0.9.6.ebuild
+++ b/dev-python/pyinotify/pyinotify-0.9.6.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6..9}} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="Python module used for monitoring filesystems events"
-HOMEPAGE="http://trac.dbzteam.org/pyinotify https://pypi.org/project/pyinotify/"
+HOMEPAGE="
+ http://trac.dbzteam.org/pyinotify
+ https://pypi.org/project/pyinotify/
+ https://github.com/seb-m/pyinotify/"
SRC_URI="http://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
LICENSE="MIT"
@@ -17,9 +20,6 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="examples"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
python_install_all() {
if use examples; then
dodoc -r python3/examples