summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-25 05:28:32 +0000
committerSam James <sam@gentoo.org>2021-11-25 05:28:40 +0000
commit9b6fa3b2f97ca2c4c204140cabcff55b6da18997 (patch)
tree6f455bf76e879cb37cf58db632c6ead63918b0ec /dev-python/pylint
parentsci-libs/indilib: skip long-suffering base64 test on ppc*, sparc (diff)
downloadgentoo-9b6fa3b2f97ca2c4c204140cabcff55b6da18997.tar.gz
gentoo-9b6fa3b2f97ca2c4c204140cabcff55b6da18997.tar.bz2
gentoo-9b6fa3b2f97ca2c4c204140cabcff55b6da18997.zip
dev-python/pylint: add 2.11.1
Closes: https://bugs.gentoo.org/818259 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.11.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 458d429e51ac..c2c9d79dee14 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1 +1,2 @@
DIST pylint-2.10.2.gh.tar.gz 813391 BLAKE2B 109f8817e32ddf8d93c9120518e77a1d2f7e61cd1a6362eb1cf9e6d242db72fa1a9271588a3abb28efca54bcc449dce623ae5d5fd63153ec2bc367e008aab465 SHA512 5d694587956c4f11eb4afaec26cefb66ccbe14dc2aacf378a0362326506d80eb2633e0d351c0a20715a3359a9bc438092d77b2e46f7f787210c7ab0555f2722f
+DIST pylint-2.11.1.gh.tar.gz 967223 BLAKE2B 435bb4589fa6dbfadfa234f8cb968a1d5c39efaf9b37fd20dfadc6feb1e997b34124386dab777b1aa1657bd9a36055d535e231181c71834517528cbbc04c698f SHA512 fe283b6eb8090414ea99809158b4e7f9fe85187ef6488ec37c5f34430793b0b4ff8afd9c97452fe0bb88efb9be001c0fd9f9a09a23081cb79084ae409b277f34
diff --git a/dev-python/pylint/pylint-2.11.1.ebuild b/dev-python/pylint/pylint-2.11.1.ebuild
new file mode 100644
index 000000000000..a22b9b25c94f
--- /dev/null
+++ b/dev-python/pylint/pylint-2.11.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint/"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/astroid-2.9[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest tests
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}