summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2021-06-07 17:56:33 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2021-06-10 19:40:51 +0200
commitd61c5685152b1159c06cf7c07d321139df101e38 (patch)
treeb14ab61727c7fdcbddf46fa34387c18381302eb3 /dev-python/pynest2d
parentdev-libs/libsavitar: Version bump to 4.9.1 (diff)
downloadgentoo-d61c5685152b1159c06cf7c07d321139df101e38.tar.gz
gentoo-d61c5685152b1159c06cf7c07d321139df101e38.tar.bz2
gentoo-d61c5685152b1159c06cf7c07d321139df101e38.zip
dev-python/pynest2d: Version bump to 4.9.1
Closes: https://bugs.gentoo.org/793803 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Mathy Vanvoorden <mathy@vanvoorden.be> Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/pynest2d')
-rw-r--r--dev-python/pynest2d/Manifest1
-rw-r--r--dev-python/pynest2d/pynest2d-4.9.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pynest2d/Manifest b/dev-python/pynest2d/Manifest
index 0bb7ea88612a..e4ed60dca6da 100644
--- a/dev-python/pynest2d/Manifest
+++ b/dev-python/pynest2d/Manifest
@@ -1 +1,2 @@
DIST pynest2d-4.8.0.tar.gz 18174 BLAKE2B 3720815b3d5ba5d4a0dd24ec4104af318d2d7f2e86e66ada68ead8249ed28184d9a153995f143cc4e00d603804da959a086a27decfe2b1e0ef00256a891e0d17 SHA512 1304450f94589b5212f11d83fb228f0deb919698b44b1651f248105c23b65cf3d233e67526bbfb47df74b9b18d0c465f4188d02a0a6941564b551f50d9a3c84f
+DIST pynest2d-4.9.1.tar.gz 18252 BLAKE2B ea98af68e7b60d615eaf6e90a68b37f8e26aa181fafecc2470b5d93d1d20a9667f5a8c903be87d419cedf47befd4e9ce757a90880c0ef19e7bb920147b2443b2 SHA512 f208e13cace4345fe691beebfe61895cbf81b7f90c19adf6a63b592928abd8591fed5c10e5b12d60c375684398856ea8d569fe8d1893a049e45d89b0ffcfc51d
diff --git a/dev-python/pynest2d/pynest2d-4.9.1.ebuild b/dev-python/pynest2d/pynest2d-4.9.1.ebuild
new file mode 100644
index 000000000000..44552bf132f5
--- /dev/null
+++ b/dev-python/pynest2d/pynest2d-4.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Python bindings for libnest2d"
+HOMEPAGE="https://github.com/Ultimaker/pynest2d"
+SRC_URI="https://github.com/Ultimaker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libnest2d
+ $(python_gen_cond_dep '<dev-python/sip-5[${PYTHON_MULTI_USEDEP}]')
+ "
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.0-required-flags-from-Libnest2D-target.patch
+ "${FILESDIR}"/${PN}-4.8.0-fix-cpp-version.patch
+)