summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-04-04 15:35:06 +0200
committerJeroen Roovers <jer@gentoo.org>2018-04-04 15:35:06 +0200
commit69f8b1e95876b7479cce265da43901dfbb8961a0 (patch)
tree6b4b6b845cbc1c021483da2de742fee1e5acfd1e /dev-python/pyparted
parentdev-lang/php: Fix compilation with dev-libs/oniguruma-6.8.1 (diff)
downloadgentoo-69f8b1e95876b7479cce265da43901dfbb8961a0.tar.gz
gentoo-69f8b1e95876b7479cce265da43901dfbb8961a0.tar.bz2
gentoo-69f8b1e95876b7479cce265da43901dfbb8961a0.zip
dev-python/pyparted: Version 3.11.1.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/Manifest1
-rw-r--r--dev-python/pyparted/pyparted-3.11.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyparted/Manifest b/dev-python/pyparted/Manifest
index cd239493f0a9..5ee41eb6f6df 100644
--- a/dev-python/pyparted/Manifest
+++ b/dev-python/pyparted/Manifest
@@ -1 +1,2 @@
DIST pyparted-3.10.7.tar.gz 99879 BLAKE2B f2d03415ec7623fbe25aeab70e53646aa5e576e9f20ac41ffe6c859be9572874579f5720b8d05191107f4143e2c6dd14d83a05798a345fa0ed8a81ce2634f599 SHA512 c57fed2a8d04511b12891fd59b6dd6840439aada7e5ebeab14a56e6e4f201c249046ee87d9d25af1b3f02960994efb0a2973f25928a9df85d48bbd1bc196ab07
+DIST pyparted-3.11.1.tar.gz 100585 BLAKE2B ee41f0c47e9432b68a2dbb8232bff63ded548d3b2867e3a1fdd891ce1f5ea1815b0c6b47416ae66e0b545c4b44065d158f2ec8ce2ff4784238e2b09bd12edc04 SHA512 4fe627693db803a82cacb37be8f2bee3527ee8d0d564229d7328a4e5c8dfa7cdd7a06c328ac7fa6b07c8f0c74d5db304410eaf312a60a0d494525d32c873fefd
diff --git a/dev-python/pyparted/pyparted-3.11.1.ebuild b/dev-python/pyparted/pyparted-3.11.1.ebuild
new file mode 100644
index 000000000000..96a9a6ec5aba
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.11.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/rhinstaller/pyparted/"
+SRC_URI="${HOMEPAGE}archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="
+ test? ( python_targets_python2_7 )
+"
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.10.3-greater.patch
+)
+
+python_test() {
+ emake test
+}