summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyprof2calltree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyprof2calltree')
-rw-r--r--dev-python/pyprof2calltree/Manifest2
-rw-r--r--dev-python/pyprof2calltree/metadata.xml8
-rw-r--r--dev-python/pyprof2calltree/pyprof2calltree-1.3.1.ebuild19
-rw-r--r--dev-python/pyprof2calltree/pyprof2calltree-1.3.2.ebuild19
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyprof2calltree/Manifest b/dev-python/pyprof2calltree/Manifest
new file mode 100644
index 000000000000..466a34f65f78
--- /dev/null
+++ b/dev-python/pyprof2calltree/Manifest
@@ -0,0 +1,2 @@
+DIST pyprof2calltree-1.3.1.tar.gz 6565 SHA256 3afdd4e6ba4d5d02fcf4815f9eebb816c0f74ba936ae34a7e264f26739be1f89 SHA512 ba939fe9ab28066067dc0989221acbf8d5c84b5cdb68850fd90b4579f8ab812883561447ae61cc896b5e461591ba5b1e40e666e21f8a824071b9c98d80e583a9 WHIRLPOOL 1120d15deb1409eb70d9af1483fa0392be124f70848b86779dea1ef5753cef03a3c82b83bc692a1d2ea1e848f0045206d85d2af9bb99b5c429946f8f9c1a35ac
+DIST pyprof2calltree-1.3.2.tar.gz 6609 SHA256 28eac89262d0edd86ee2574d24d1840cbca2d4ed6a1de7e1d8fc05f30ea5a22b SHA512 e85c5a21fe52b246ee6080f59e2ff115b43e3ab634e2842aff0d493b8b996105e0c1698e049ae7d11ea53c1f1fd601ef5f12c6fba62dcea28ddff23ec61a2736 WHIRLPOOL b132fe3179bbf7e3dc999fe3f8da1fdb298b515c302e76de4d96cff4392966875df8180aba66b535a122c8521d22755efbc9f46a133f8a758cce0a230d943bc3
diff --git a/dev-python/pyprof2calltree/metadata.xml b/dev-python/pyprof2calltree/metadata.xml
new file mode 100644
index 000000000000..603d5e5f4f91
--- /dev/null
+++ b/dev-python/pyprof2calltree/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyprof2calltree</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.3.1.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.3.1.ebuild
new file mode 100644
index 000000000000..429b3d83f4d0
--- /dev/null
+++ b/dev-python/pyprof2calltree/pyprof2calltree-1.3.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="convert python profile data to kcachegrind calltree form"
+HOMEPAGE="http://pypi.python.org/pypi/pyprof2calltree/"
+SRC_URI="mirror://pypi/p/${PN}/${PF}.tar.gz"
+IUSE=
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.3.2.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.3.2.ebuild
new file mode 100644
index 000000000000..429b3d83f4d0
--- /dev/null
+++ b/dev-python/pyprof2calltree/pyprof2calltree-1.3.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="convert python profile data to kcachegrind calltree form"
+HOMEPAGE="http://pypi.python.org/pypi/pyprof2calltree/"
+SRC_URI="mirror://pypi/p/${PN}/${PF}.tar.gz"
+IUSE=
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"