summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-03 19:43:09 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-03 19:43:36 +0200
commit079cc1b16a6d47762aaec9235d6dcf7c71d9c786 (patch)
treea7ea4b16ccc028657f7e5a8b94211f7dbc4a30c6 /dev-python/pyproj
parentdev-util/debhelper: Old. (diff)
downloadgentoo-079cc1b16a6d47762aaec9235d6dcf7c71d9c786.tar.gz
gentoo-079cc1b16a6d47762aaec9235d6dcf7c71d9c786.tar.bz2
gentoo-079cc1b16a6d47762aaec9235d6dcf7c71d9c786.zip
dev-python/pyproj: Fix tests
Thanks-to: Mike Gilbert <floppym@gentoo.org> Closes: https://bugs.gentoo.org/623354 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/pyproj-1.9.5.1.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/dev-python/pyproj/pyproj-1.9.5.1.ebuild b/dev-python/pyproj/pyproj-1.9.5.1.ebuild
index a39b855d09fa..78294d37ee3f 100644
--- a/dev-python/pyproj/pyproj-1.9.5.1.ebuild
+++ b/dev-python/pyproj/pyproj-1.9.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
inherit distutils-r1 flag-o-matic
@@ -24,12 +24,7 @@ python_prepare_all() {
}
python_test() {
- einfo "Testruns do not have regular unittest type tests, instead for test.py,"
- einfo "the output need be compared with a separate file, sample.out."
- "${PYTHON}" test/test.py || die
-
- einfo ""; einfo "Now the file test2.py is run to test pickling"; einfo ""
- "${PYTHON}" test/test2.py || die
+ "${EPYTHON}" unittest/test.py || die
}
python_install_all() {