summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-15 18:00:11 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-16 13:33:33 +0100
commit01bb6b9ab7bbe5368ff598ad109bac9990989ac5 (patch)
treef70bbea4ab9c7133f501bc0798d0ffebe24b2808 /dev-python/pypy
parentmedia-gfx/replicatorg: Add homepage and maintainer-needed (diff)
downloadgentoo-01bb6b9ab7bbe5368ff598ad109bac9990989ac5.tar.gz
gentoo-01bb6b9ab7bbe5368ff598ad109bac9990989ac5.tar.bz2
gentoo-01bb6b9ab7bbe5368ff598ad109bac9990989ac5.zip
dev-python/pypy: Fix mtimes between generated and source files
Ensure to preserve file mtimes while copying them from the source tree to the installation image. This ensures that the generated files are newer than source files, and that PyPy does not attempt to rewrite them at runtime.
Diffstat (limited to 'dev-python/pypy')
-rw-r--r--dev-python/pypy/pypy-5.9.0-r1.ebuild (renamed from dev-python/pypy/pypy-5.9.0.ebuild)2
-rw-r--r--dev-python/pypy/pypy-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pypy/pypy-5.9.0.ebuild b/dev-python/pypy/pypy-5.9.0-r1.ebuild
index ce877adabdf4..7cfed8fcca3b 100644
--- a/dev-python/pypy/pypy-5.9.0.ebuild
+++ b/dev-python/pypy/pypy-5.9.0-r1.ebuild
@@ -241,6 +241,8 @@ src_install() {
doexe pypy-c libpypy-c.so
pax-mark m "${ED%/}${dest}/pypy-c" "${ED%/}${dest}/libpypy-c.so"
insinto "${dest}"
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
doins -r include lib_pypy lib-python
dosym ../$(get_libdir)/pypy/pypy-c /usr/bin/pypy
dodoc README.rst
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index 805c5e7f777f..fecf7b18d4e4 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -247,6 +247,8 @@ src_install() {
doexe pypy-c libpypy-c.so
pax-mark m "${ED%/}${dest}/pypy-c" "${ED%/}${dest}/libpypy-c.so"
insinto "${dest}"
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
doins -r include lib_pypy lib-python
dosym ../$(get_libdir)/pypy/pypy-c /usr/bin/pypy
dodoc README.rst