summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-31 08:28:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-31 08:55:08 +0200
commit8efd6999e4b2b58c283e96baec9603f22aa658dc (patch)
tree5f0b94ccc5d293305f9dfae34798939ecdcd34f1 /dev-python/pyquery
parentdev-python/ipython: Bump to 8.27.0 (diff)
downloadgentoo-8efd6999e4b2b58c283e96baec9603f22aa658dc.tar.gz
gentoo-8efd6999e4b2b58c283e96baec9603f22aa658dc.tar.bz2
gentoo-8efd6999e4b2b58c283e96baec9603f22aa658dc.zip
dev-python/pyquery: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyquery')
-rw-r--r--dev-python/pyquery/Manifest1
-rw-r--r--dev-python/pyquery/pyquery-2.0.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyquery/Manifest b/dev-python/pyquery/Manifest
index a6fa9d25b0f1..820978103d0f 100644
--- a/dev-python/pyquery/Manifest
+++ b/dev-python/pyquery/Manifest
@@ -1 +1,2 @@
DIST pyquery-2.0.0.tar.gz 45210 BLAKE2B 2c1d052d310541b36f526e72906681ea03e0d55be16202c98ab5d5b9f5fc408b7612a353100937381639a03f8871b8bf691c6b0d5ad09dec8cc6f2e2ced7944d SHA512 316a479acd23e371b6e70550681527b15203e7ab62f4722375335180f13d9b48d9170abf308bb26b6180d954de4f8dfea5f90426cb820c5e888cc56f8a99ba33
+DIST pyquery-2.0.1.tar.gz 44999 BLAKE2B 704e3410bf06ed06d899dab4811fbb6e2869589a5f59a4eb32800a71580e98cdb6bdac1ca3d675d8e1ccacc162ac4ba75bf15f69355658ee2aede12d0e8d50d6 SHA512 c3db13b884beb3a4b2f77b3369c7a2256eee77102a41482f73c1c663778620bc6728d500ba47b51baa3f8c47d80325622a2bac54e5d7aecf1de7679577aa5e85
diff --git a/dev-python/pyquery/pyquery-2.0.1.ebuild b/dev-python/pyquery/pyquery-2.0.1.ebuild
new file mode 100644
index 000000000000..65c1c9743097
--- /dev/null
+++ b/dev-python/pyquery/pyquery-2.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A jQuery-like library for python"
+HOMEPAGE="
+ https://github.com/gawel/pyquery/
+ https://pypi.org/project/pyquery/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
+ >=dev-python/cssselect-1.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # needs network
+ tests/test_pyquery.py::TestWebScrappingEncoding::test_get
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup4
+}