summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyro
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/Manifest2
-rw-r--r--dev-python/pyro/files/4.20-0001-Use-unittest2-for-older-Python-version.patch354
-rw-r--r--dev-python/pyro/metadata.xml12
-rw-r--r--dev-python/pyro/pyro-3.16-r1.ebuild36
-rw-r--r--dev-python/pyro/pyro-4.25.ebuild77
5 files changed, 481 insertions, 0 deletions
diff --git a/dev-python/pyro/Manifest b/dev-python/pyro/Manifest
new file mode 100644
index 000000000000..4ce71be4c390
--- /dev/null
+++ b/dev-python/pyro/Manifest
@@ -0,0 +1,2 @@
+DIST Pyro-3.16.tar.gz 298769 SHA256 1bed508453ef7a7556b51424a58101af2349b662baab7e7331c5cb85dbe7e578 SHA512 d0e4ae93120a6566a2b06fa52b66e20daa972324a9d57d639ca68171e1e6e5c412250f7e6af3fc307631d2270be3731ea5898ad35819dc0369e6a2d8341d5965 WHIRLPOOL 0d7efcead6bc7a31a690c012a4213c835d43ca932e461ab25ddb2e12636970de2c3da6feb4915385bdadaf2261558d2041d5e6dad9899f11e450aa0a065460da
+DIST Pyro4-4.25.tar.gz 295993 SHA256 ac2b0123badcb76c63eb716fcd95e0ee4021d345b5db05fda19253c59e39b384 SHA512 9a112e679a304d250549701d9a1baef0df6d3ea6f1eec559e7c433eab7ab09155c9ae440817f844be073f69dc8bf93836d48930b1d91311eaf6ab7e91c0a4faf WHIRLPOOL aa767569948af1cf222b95fa114d4dee08b601296f8be1ed9bce86502f1c9eeedf05930215da192ab9d237d740283f88a5f7efe1f53291acd1b90b51099a1801
diff --git a/dev-python/pyro/files/4.20-0001-Use-unittest2-for-older-Python-version.patch b/dev-python/pyro/files/4.20-0001-Use-unittest2-for-older-Python-version.patch
new file mode 100644
index 000000000000..554ea01321a6
--- /dev/null
+++ b/dev-python/pyro/files/4.20-0001-Use-unittest2-for-older-Python-version.patch
@@ -0,0 +1,354 @@
+From d27de91579bd64397a9554b6c6a2257f098dbaad Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Thu, 18 Jul 2013 20:19:03 +0200
+Subject: [PATCH] Use unittest2 for older Python versions.
+
+---
+ tests/PyroTests/test_core.py | 6 +++++-
+ tests/PyroTests/test_daemon.py | 7 ++++++-
+ tests/PyroTests/test_echoserver.py | 7 ++++++-
+ tests/PyroTests/test_flame.py | 7 ++++++-
+ tests/PyroTests/test_ironpython.py | 6 +++++-
+ tests/PyroTests/test_naming.py | 7 ++++++-
+ tests/PyroTests/test_naming2.py | 6 +++++-
+ tests/PyroTests/test_package.py | 7 ++++++-
+ tests/PyroTests/test_serialize.py | 6 +++++-
+ tests/PyroTests/test_server.py | 6 +++++-
+ tests/PyroTests/test_server_timeout.py | 7 ++++++-
+ tests/PyroTests/test_socket.py | 6 +++++-
+ tests/PyroTests/test_tpjobqueue.py | 7 ++++++-
+ tests/PyroTests/test_util.py | 7 +++++--
+ 14 files changed, 77 insertions(+), 15 deletions(-)
+
+diff --git a/tests/PyroTests/test_core.py b/tests/PyroTests/test_core.py
+index cbcbded..a0b801f 100644
+--- a/tests/PyroTests/test_core.py
++++ b/tests/PyroTests/test_core.py
+@@ -5,7 +5,6 @@ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+ from __future__ import with_statement
+-import unittest
+ import copy
+ import logging
+ import os, sys, time
+@@ -17,6 +16,11 @@ import Pyro4.constants
+ import Pyro4.futures
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ if sys.version_info>=(3,0):
+ import imp
+diff --git a/tests/PyroTests/test_daemon.py b/tests/PyroTests/test_daemon.py
+index cf7c06e..05472fd 100644
+--- a/tests/PyroTests/test_daemon.py
++++ b/tests/PyroTests/test_daemon.py
+@@ -5,14 +5,19 @@ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+ from __future__ import with_statement
++import sys
+ import os, time, socket
+-import unittest
+ import Pyro4.core
+ import Pyro4.constants
+ import Pyro4.socketutil
+ from Pyro4.errors import DaemonError,PyroError
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ class MyObj(object):
+ def __init__(self, arg):
+diff --git a/tests/PyroTests/test_echoserver.py b/tests/PyroTests/test_echoserver.py
+index abca795..5e58e24 100644
+--- a/tests/PyroTests/test_echoserver.py
++++ b/tests/PyroTests/test_echoserver.py
+@@ -4,13 +4,18 @@ Tests for the built-in test echo server.
+ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+-import unittest
++import sys
+ import time
+ import Pyro4.test.echoserver as echoserver
+ import Pyro4
+ from threading import Thread,Event
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ class EchoServerThread(Thread):
+ def __init__(self):
+diff --git a/tests/PyroTests/test_flame.py b/tests/PyroTests/test_flame.py
+index 2406bae..fdc611f 100644
+--- a/tests/PyroTests/test_flame.py
++++ b/tests/PyroTests/test_flame.py
+@@ -5,12 +5,17 @@ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+ from __future__ import with_statement
+-import unittest
+ import Pyro4.utils.flame
+ import Pyro4.utils.flameserver
+ import Pyro4.errors
++import sys
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ class FlameDisabledTests(unittest.TestCase):
+ def testFlameDisabled(self):
+diff --git a/tests/PyroTests/test_ironpython.py b/tests/PyroTests/test_ironpython.py
+index 70dff4f..8343729 100644
+--- a/tests/PyroTests/test_ironpython.py
++++ b/tests/PyroTests/test_ironpython.py
+@@ -4,10 +4,14 @@ Tests for some Ironpython peculiarities.
+ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+-import unittest
+ import sys
+ import pickle
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ if sys.platform=="cli":
+
+diff --git a/tests/PyroTests/test_naming.py b/tests/PyroTests/test_naming.py
+index d61fa99..fb5b580 100644
+--- a/tests/PyroTests/test_naming.py
++++ b/tests/PyroTests/test_naming.py
+@@ -5,7 +5,7 @@ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+ from __future__ import with_statement
+-import unittest
++import sys
+ import time
+ import Pyro4.core
+ import Pyro4.naming
+@@ -15,6 +15,11 @@ from Pyro4.errors import NamingError
+ from Pyro4 import threadutil
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ class NSLoopThread(threadutil.Thread):
+ def __init__(self, nameserver):
+diff --git a/tests/PyroTests/test_naming2.py b/tests/PyroTests/test_naming2.py
+index afa0b22..ae398ac 100644
+--- a/tests/PyroTests/test_naming2.py
++++ b/tests/PyroTests/test_naming2.py
+@@ -5,7 +5,6 @@ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+ from __future__ import with_statement
+-import unittest
+ import sys, select, os
+ import Pyro4.core
+ import Pyro4.naming
+@@ -15,6 +14,11 @@ import Pyro4.socketutil
+ from Pyro4.errors import NamingError,PyroError
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ class OfflineNameServerTests(unittest.TestCase):
+ def setUp(self):
+diff --git a/tests/PyroTests/test_package.py b/tests/PyroTests/test_package.py
+index 9ab3bba..052eebf 100644
+--- a/tests/PyroTests/test_package.py
++++ b/tests/PyroTests/test_package.py
+@@ -4,7 +4,6 @@ Tests for the package structure and import names.
+ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+-import unittest
+ import Pyro4
+ import Pyro4.constants
+ import Pyro4.core
+@@ -14,7 +13,13 @@ import Pyro4.nsc
+ import Pyro4.socketutil
+ import Pyro4.threadutil
+ import Pyro4.util
++import sys
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ class TestPackage(unittest.TestCase):
+ def testPyro4(self):
+diff --git a/tests/PyroTests/test_serialize.py b/tests/PyroTests/test_serialize.py
+index 4fea39c..f05c84a 100644
+--- a/tests/PyroTests/test_serialize.py
++++ b/tests/PyroTests/test_serialize.py
+@@ -5,7 +5,6 @@ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+ from __future__ import with_statement
+-import unittest
+ import sys
+ import pprint
+ import Pyro4.util
+@@ -13,6 +12,11 @@ import Pyro4.errors
+ import Pyro4.core
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ class SerializeTests_pickle(unittest.TestCase):
+ SERIALIZER="pickle"
+diff --git a/tests/PyroTests/test_server.py b/tests/PyroTests/test_server.py
+index d1ebfcc..b2dd661 100644
+--- a/tests/PyroTests/test_server.py
++++ b/tests/PyroTests/test_server.py
+@@ -5,7 +5,6 @@ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+ from __future__ import with_statement
+-import unittest
+ import Pyro4.core
+ import Pyro4.errors
+ import Pyro4.util
+@@ -13,6 +12,11 @@ import time, os, sys, platform
+ from Pyro4 import threadutil
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ class MyThing(object):
+ def __init__(self):
+diff --git a/tests/PyroTests/test_server_timeout.py b/tests/PyroTests/test_server_timeout.py
+index daa5a8d..dd5ee34 100644
+--- a/tests/PyroTests/test_server_timeout.py
++++ b/tests/PyroTests/test_server_timeout.py
+@@ -4,10 +4,15 @@ Tests for a running Pyro server, with timeouts.
+ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+-import unittest
++import sys
+ import os
+ import test_server
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ class ServerTestsThreadTimeout(test_server.ServerTestsThreadNoTimeout):
+ SERVERTYPE="thread"
+diff --git a/tests/PyroTests/test_socket.py b/tests/PyroTests/test_socket.py
+index 4d44139..b487686 100644
+--- a/tests/PyroTests/test_socket.py
++++ b/tests/PyroTests/test_socket.py
+@@ -4,7 +4,6 @@ Tests for the low level socket functions.
+ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+-import unittest
+ import socket, os, sys
+ import Pyro4.socketutil as SU
+ from Pyro4 import threadutil
+@@ -13,6 +12,11 @@ from Pyro4.socketserver.threadpoolserver import SocketServer_Threadpool
+ import Pyro4
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ # determine ipv6 capability
+ has_ipv6 = socket.has_ipv6
+diff --git a/tests/PyroTests/test_tpjobqueue.py b/tests/PyroTests/test_tpjobqueue.py
+index 8ab7f7b..7cdc3bb 100644
+--- a/tests/PyroTests/test_tpjobqueue.py
++++ b/tests/PyroTests/test_tpjobqueue.py
+@@ -5,12 +5,17 @@ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+ from __future__ import with_statement
+-import unittest
++import sys
+ import time
+ import random
+ from Pyro4.tpjobqueue import ThreadPooledJobQueue, JobQueueError
+ import Pyro4.threadutil
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ MIN_POOL_SIZE = 5
+ MAX_POOL_SIZE = 10
+diff --git a/tests/PyroTests/test_util.py b/tests/PyroTests/test_util.py
+index ac1e639..497ec4a 100644
+--- a/tests/PyroTests/test_util.py
++++ b/tests/PyroTests/test_util.py
+@@ -4,12 +4,15 @@ Tests for the utility functions.
+ Pyro - Python Remote Objects. Copyright by Irmen de Jong (irmen@razorvine.net).
+ """
+
+-import unittest
+-
+ import sys, imp, os, platform
+ import Pyro4.util
+ from testsupport import *
+
++if (sys.version_info >= (2, 7) and sys.version_info < (3, 0)) or \
++ (sys.version_info >= (3, 1)):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ if not hasattr(imp,"reload"):
+ imp.reload=reload # python 2.5 doesn't have imp.reload
+--
+1.8.2.1
+
diff --git a/dev-python/pyro/metadata.xml b/dev-python/pyro/metadata.xml
new file mode 100644
index 000000000000..5699b06419b1
--- /dev/null
+++ b/dev-python/pyro/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Pyro</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyro/pyro-3.16-r1.ebuild b/dev-python/pyro/pyro-3.16-r1.ebuild
new file mode 100644
index 000000000000..a9fe60240cb0
--- /dev/null
+++ b/dev-python/pyro/pyro-3.16-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="Pyro"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://www.xs4all.nl/~irmen/pyro3/ http://pypi.python.org/pypi/Pyro"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+DEPEND="!dev-python/pyro:0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/${P}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/pyro/pyro-4.25.ebuild b/dev-python/pyro/pyro-4.25.ebuild
new file mode 100644
index 000000000000..c03b2afe2a7b
--- /dev/null
+++ b/dev-python/pyro/pyro-4.25.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Pyro4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="!dev-python/pyro:0
+ >=dev-python/serpent-1.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed \
+ -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' \
+ -i tests/run_suite.py || die
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/testBCstart/_&/" \
+ -e "s/testDaemonPyroObj/_&/" \
+ -e "s/testLookupAndRegister/_&/" \
+ -e "s/testMulti/_&/" \
+ -e "s/testRefuseDottedNames/_&/" \
+ -e "s/testResolve/_&/" \
+ -e "s/testBCLookup/_&/" \
+ -i tests/PyroTests/test_naming.py || die
+ sed \
+ -e "s/testOwnloopBasics/_&/" \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/test_naming2.py || die
+
+ sed \
+ -e "s/testServerConnections/_&/" \
+ -e "s/testServerParallelism/_&/" \
+ -i tests/PyroTests/test_server.py || die
+
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -e "s/testGetIpVersion[46]/_&/" \
+ -i tests/PyroTests/test_socket.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${S}"/tests || die
+ ${PYTHON} run_suite.py || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}