summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-01-22 12:55:04 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-01-22 13:33:29 +0100
commit15a1841e639dbfc94909b5bf4fbe881baaf440e2 (patch)
tree4f336c24d555b295ba08e1955c83e22c37654ca5 /dev-python/pysrt
parentnet-proxy/squidguard: fix QA issue with automake call in src_prepare (diff)
downloadgentoo-15a1841e639dbfc94909b5bf4fbe881baaf440e2.tar.gz
gentoo-15a1841e639dbfc94909b5bf4fbe881baaf440e2.tar.bz2
gentoo-15a1841e639dbfc94909b5bf4fbe881baaf440e2.zip
dev-python/pysrt: bump to 1.1.2, add Python 3.8 support
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/Manifest1
-rw-r--r--dev-python/pysrt/pysrt-1.1.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pysrt/Manifest b/dev-python/pysrt/Manifest
index 2c86a5e5eee2..42fd6594f3a2 100644
--- a/dev-python/pysrt/Manifest
+++ b/dev-python/pysrt/Manifest
@@ -1 +1,2 @@
DIST pysrt-1.1.1.tar.gz 104027 BLAKE2B a035234d687a6d7e69123a012087b8d065cad3904ce422b3a4390b0f6a0ad8471e35d7f5d9cd7e835ff2238566dd0b7a40a039b88d5b6d3a4be464e390847d79 SHA512 607f80c1f66702d36b6fa54b293f59c6a28415d812bf54d7210075d1c84a7547ce2776c0809910ed3d79c08a3c595ce74719976d8f2818820a3f4a306ffc1825
+DIST pysrt-1.1.2.tar.gz 104371 BLAKE2B b6f8e1e6d0cc0ae7ac4a5eb1ac9c5444318fd579fd2cbd926bed932326c986743d3efc1b604353df92a3dc67ea0d47f9a77eeba28d561b3f69b4b63eff8b78ad SHA512 a3a0988068d3cc13e6d44aec548a94e79d9ed29cfcd1e8e35ff56b50f0feb32a1baac2220c5331281c98a19ad9a3e9f960832a661699921cde0d185ea21e9753
diff --git a/dev-python/pysrt/pysrt-1.1.2.ebuild b/dev-python/pysrt/pysrt-1.1.2.ebuild
new file mode 100644
index 000000000000..766998ae2d3e
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests failed under ${EPYTHON}"
+}