summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2021-05-16 01:52:52 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-18 13:39:54 +0200
commit7a0ed69b9c073553482ad64d0c955f7189e267be (patch)
treebee51ea0cf0f52c56ecf03bad5b7cb070f927d8b /dev-python/pytest-asyncio
parentdev-python/automat: Bump to python 3.10 (diff)
downloadgentoo-7a0ed69b9c073553482ad64d0c955f7189e267be.tar.gz
gentoo-7a0ed69b9c073553482ad64d0c955f7189e267be.tar.bz2
gentoo-7a0ed69b9c073553482ad64d0c955f7189e267be.zip
dev-python/pytest-asyncio: Bump to python 3.10
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/files/pytest-asyncio-0.15.1-310-test-warnings.patch12
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild6
2 files changed, 17 insertions, 1 deletions
diff --git a/dev-python/pytest-asyncio/files/pytest-asyncio-0.15.1-310-test-warnings.patch b/dev-python/pytest-asyncio/files/pytest-asyncio-0.15.1-310-test-warnings.patch
new file mode 100644
index 000000000000..50f1c9f2d168
--- /dev/null
+++ b/dev-python/pytest-asyncio/files/pytest-asyncio-0.15.1-310-test-warnings.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.cfg b/setup.cfg
+index 0161086..047501c 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -8,6 +8,7 @@ show_missing = true
+ addopts = -rsx --tb=short
+ testpaths = tests
+ filterwarnings = error
++ ignore::DeprecationWarning
+
+ [metadata]
+ # ensure LICENSE is included in wheel metadata
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
index 60f1a55ba4e7..eef2f9adf10d 100644
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -23,4 +23,8 @@ BDEPEND="
>=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}/${P}-310-test-warnings.patch"
+)
+
distutils_enable_tests --install pytest