summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-02 17:39:59 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-02 17:40:30 +0100
commita6614d15e6c60c57d7da2e16c99795b1dcb9a245 (patch)
tree6061bff40ea3f5f7b98a613facb4cec8bf73820c /dev-python/pytest-asyncio
parentmedia-sound/daudio: Remove last-rited pkg (diff)
downloadgentoo-a6614d15e6c60c57d7da2e16c99795b1dcb9a245.tar.gz
gentoo-a6614d15e6c60c57d7da2e16c99795b1dcb9a245.tar.bz2
gentoo-a6614d15e6c60c57d7da2e16c99795b1dcb9a245.zip
dev-python/pytest-asyncio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest3
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.3.ebuild49
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.4_alpha1.ebuild49
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.4_alpha2.ebuild49
4 files changed, 0 insertions, 150 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 765f24b36da9..c69d4758d9a4 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,5 +1,2 @@
DIST pytest-asyncio-0.23.2.tar.gz 44174 BLAKE2B 36dbd0022416eef05c781b9f74fd143bb52fe0583461ca7e52fd4981d552bbefdddd8e3a3399bc229a8ae68b150e199237ae0ce3a375075ab8f7f507bfa59316 SHA512 aa5b5fe8b633b187303dd2958d2ea01561604044507da107e46115d9bf4c1ac3c78826b4b6a6cbf474a6ee4ce0cd1bede87a2c8fe0d35397ddf6a4069437dd84
-DIST pytest-asyncio-0.23.3.tar.gz 44841 BLAKE2B f40f18e683ff1c6d905ae81c0a399655d461065f49fc862fe0d57c9d0deb14795e9792d76ea9759ea2b8736f7815de8c1778dbcaa8f477c59cbffd1f991e7ed1 SHA512 209a36de4d74bb3ade486b7c89c58def33b4aca84b3a096012d2ba329946f084a3f70489fb4ba0682e6acd65b6862e2ea4104a8e8912e8693f4f1685de357762
DIST pytest-asyncio-0.23.4.tar.gz 45162 BLAKE2B 69092bff908beb2b707d281142145edf0508bcb09aa59e4a91d18b3cdb24e5533436a9668e2d243425b4914f2913e6186fa6d8b6c1d187b6bf25191986d27981 SHA512 831c572ae981b8575f97dd4d0d40d960d49cbeeb6b186e1c094eb45b1f48210824780ca14cbf44d1da558b1a17ca1fefc0eda26137461172bbd12f8b25ab8ebb
-DIST pytest-asyncio-0.23.4a1.tar.gz 46294 BLAKE2B 6015cc43a8eae8a589311a579196ca9ebb392ff14cf3c68743e10ea3bf7b57958aba59432efae94c3e57e03be3f625a1f0c883e85427af3a20d1f60d634d8946 SHA512 9181a65ad427d2a0f35077019dfa6a46d5714592a754a083a7bb0efb7f97af5776192cd92961d751dba27d84c78a32a9f0c49a46b2d962d24796451311845691
-DIST pytest-asyncio-0.23.4a2.tar.gz 45187 BLAKE2B b9c7b48c2ddc29f57e7a175d4cd2a86431047223d23d2a516338b2d2e12951a422eff09736737755777b6fc764e50942b21497d53515319494d8c17100856f9c SHA512 f8d21483935c9d92b50519e71a9f88776bb10ac8d7112fd290d03d35f484177406e9a094be6ab4383a733b40a6166def97dcea881a13e82bbdbe94725aa6a070
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.3.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.3.ebuild
deleted file mode 100644
index f54360ce4842..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.23.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
- tests/modes/test_legacy_mode.py
- tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
- tests/test_pytest_min_version_warning.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
- epytest
-}
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.4_alpha1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.4_alpha1.ebuild
deleted file mode 100644
index f54360ce4842..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.23.4_alpha1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
- tests/modes/test_legacy_mode.py
- tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
- tests/test_pytest_min_version_warning.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
- epytest
-}
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.4_alpha2.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.4_alpha2.ebuild
deleted file mode 100644
index f54360ce4842..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.23.4_alpha2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
- tests/modes/test_legacy_mode.py
- tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
- tests/test_pytest_min_version_warning.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
- epytest
-}