summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-18 17:56:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-18 17:56:41 +0200
commitdb9452ce18b5ce718f512ae6e8e37216fe80d985 (patch)
tree75a990de9e009e52824763f7b7d026533e1cb5f6 /dev-python/pytest-httpbin
parentdev-lang/gnat-gpl: cleanup PYTHON_COMPAT debris (diff)
downloadgentoo-db9452ce18b5ce718f512ae6e8e37216fe80d985.tar.gz
gentoo-db9452ce18b5ce718f512ae6e8e37216fe80d985.tar.bz2
gentoo-db9452ce18b5ce718f512ae6e8e37216fe80d985.zip
dev-python/pytest-httpbin: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest1
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-2.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
index d7f45743003d..3d0dfa08d053 100644
--- a/dev-python/pytest-httpbin/Manifest
+++ b/dev-python/pytest-httpbin/Manifest
@@ -1 +1,2 @@
DIST pytest-httpbin-2.0.0.gh.tar.gz 19799 BLAKE2B 7725bc958417c076ee920abce83bdad8295bc4c9551500040867650d54c306e79a1ea92b013124b793058103fc9685dbb2202be5f1b2da935509f68457d63d68 SHA512 62876590bacae6601739f5cc2eccb087024e16731afc9613b5e6928c2a2f64b73418ddcb3c4f13a4bfe1f074510f922d85411d05ebf66f123a4a09d535771b64
+DIST pytest-httpbin-2.1.0.gh.tar.gz 13140 BLAKE2B d1108b8464dbc1075007b4695810afe46fed17b51a785f12dfa184ba27efcfe88818ab8073c050334398eecfd647cd9169ef2d053e3fb424a02ece8a8d8c1518 SHA512 849985f170318ea3ad1d2af8811f3e3fef0e62bd6bdc611f061a8cd7d84a2d85d0ba9caf8c97298e1c99b979b08f1a28476927fa7abc1fa57334732ecfbdf2db
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-2.1.0.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-2.1.0.ebuild
new file mode 100644
index 000000000000..302d6d0a6faf
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="
+ https://github.com/kevin1024/pytest-httpbin/
+ https://pypi.org/project/pytest-httpbin/
+"
+SRC_URI="
+ https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/httpbin[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest