summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 23:18:26 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 23:18:26 +0200
commit37cbacf459bbc890a2b06e9356b3f6a62b8588c4 (patch)
treedf8786cc71ee77d65fdfb8abbc13f05c08d91b7f /dev-python/pytest-mock
parentdev-python/pylast: Remove old (diff)
downloadgentoo-37cbacf459bbc890a2b06e9356b3f6a62b8588c4.tar.gz
gentoo-37cbacf459bbc890a2b06e9356b3f6a62b8588c4.tar.bz2
gentoo-37cbacf459bbc890a2b06e9356b3f6a62b8588c4.zip
dev-python/pytest-mock: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest2
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.5.1.ebuild36
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.6.0.ebuild32
3 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 1244c4ba7055..c05c153f9057 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,3 +1 @@
-DIST pytest-mock-3.5.1.tar.gz 29135 BLAKE2B f9eb37bff0965772919c359ad56a0cdd0cac24fa763685c42ffaa2dfaea183a9c0be480269cbfc80990baaf406021c541b6dccc09602e98c8f731bbd530e928a SHA512 28ab2f239d3dfee134dd4e4fd467109cf3c76cb60aeb537dbc0c21b9a7619d068d54737e33d98c585e9341588fdafba4737ea5f428af37796f55e61ec30373a7
-DIST pytest-mock-3.6.0.tar.gz 29795 BLAKE2B ac0a9ebf47ceacaa6f1e109571a15509780ca25b67f46a74710fb81e3af4cb90f4bf95e077abd9c5be803fed1a4dfe691f57f4b0d89fbc91cb91ed85fd326f9b SHA512 158614ad655545a95134335b6ca5ab81bfae57a045a6e394c4195d267e2b5cce277302036ad7e23e3c771eaae71575b901ac3e02a734714d63ecb50c11b9df94
DIST pytest-mock-3.6.1.tar.gz 29933 BLAKE2B 6c22d23f3a8e9b5ef26f990325f5a2c2897b60f61f84472716a1f984e72a8c38f6992e439ef581d7772e25a5fe9e76d190697d9c7bc8b5dcbf6375bead4b3dc3 SHA512 50a8ffbac1b20b1962558789b24d50c1e7d8d2e2706ee15a576eb5fd1b40d4523482dce7a1078d532b686ff8d38b6d769d356b04241528a0196e14acae0b6199
diff --git a/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild
deleted file mode 100644
index 17ca5abbe94f..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- if has_version dev-python/mock; then
- # test fails when standalone mock is installed
- sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i tests/test_pytest_mock.py || die
- fi
- distutils-r1_src_prepare
-}
-
-python_test() {
- distutils_install_for_testing
- pytest --assert=plain -vv || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild
deleted file mode 100644
index 074f1d7ea000..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
-
-RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=()
- if has_version dev-python/mock; then
- deselect+=(
- tests/test_pytest_mock.py::test_standalone_mock
- )
- fi
-
- distutils_install_for_testing
- epytest --assert=plain ${deselect[@]/#/--deselect }
-}