summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-26 05:39:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-26 05:49:35 +0200
commit92b15eec587b55d48ea5eb8bb48a859a4a34f3a6 (patch)
tree98ac3e5d423b1a1b7633c8729e43edb8c7308cba /dev-python/pytest-qt
parentdev-python/readthedocs-sphinx-ext: Bump to 2.2.0 (diff)
downloadgentoo-92b15eec587b55d48ea5eb8bb48a859a4a34f3a6.tar.gz
gentoo-92b15eec587b55d48ea5eb8bb48a859a4a34f3a6.tar.bz2
gentoo-92b15eec587b55d48ea5eb8bb48a859a4a34f3a6.zip
dev-python/pytest-qt: Bump to 4.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest1
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.2.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index 794f27a65f05..ef415126fbe8 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1 +1,2 @@
DIST pytest-qt-4.1.0.tar.gz 119702 BLAKE2B 7c906c94761df6472ae65a6ebb38dff07de8156730e3e10615ea8e08f0bd9f9fee07127ee6e8616055117b1db1911bc9b4486345d84b249664d317561195ad77 SHA512 bfb56abbaac47bf9da26eb19d6913d59872f2a9923da339e9a30a2145d0a094ddec36bcfa21d39c4cf318f95a83c72c249fe70034294a6791f9d84345f77451d
+DIST pytest-qt-4.2.0.tar.gz 120749 BLAKE2B 1986bbf4ebc578ad548d2fcc8888b0d0fb42f75ad8a03f315f51c04ae466587d3299fca8ec3a49bc5d023fc8ca76cbe6c45728bc88609e20d6f68ea8c6ea204e SHA512 57e175bada0e33101eeb7d85579f6e804658d74168714b117b3a1ba564826405e70860b258caf28c917ddca7acd1842de2133a55b342862762fc37ca1a758b69
diff --git a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
new file mode 100644
index 000000000000..69dbc6a6d79f
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYSIDE2_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Pytest plugin for PyQt5 and PySide2 applications"
+HOMEPAGE="
+ https://pypi.org/project/pytest-qt/
+ https://github.com/pytest-dev/pytest-qt/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
+ ' "${PYSIDE2_COMPAT[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # warnings from other plugins cause the test output matchers to fail
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytestqt.plugin
+
+ local EPYTEST_DESELECT=(
+ # requires the window to be activated; that doesn't seem
+ # to be possible inside Xvfb
+ "tests/test_basics.py::test_wait_window[waitActive-True]"
+
+ # we are forcing a specific module via envvar, effectively
+ # overriding the config
+ tests/test_basics.py::test_qt_api_ini_config
+ tests/test_basics.py::test_qt_api_ini_config_with_envvar
+ )
+
+ einfo "Testing with PyQt5"
+ PYTEST_QT_API="pyqt5" epytest || die
+ # Pyside2 is not compatible with python3.11
+ if has "${EPYTHON}" "${PYSIDE2_COMPAT[@]/_/.}"; then
+ einfo "Testing with PySide2"
+ PYTEST_QT_API="pyside2" epytest || die
+ fi
+}