summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-11-09 16:11:16 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-11-09 16:12:28 -0800
commit139158d87cbdf903094e55178ebbf03348e1a27b (patch)
tree94ae75a30ca40e0992ac649647d6b01d3a38722d /dev-python/python-iptables
parentsys-auth/rtkit: Stabilize 0.13-r1 arm, #753179 (diff)
downloadgentoo-139158d87cbdf903094e55178ebbf03348e1a27b.tar.gz
gentoo-139158d87cbdf903094e55178ebbf03348e1a27b.tar.bz2
gentoo-139158d87cbdf903094e55178ebbf03348e1a27b.zip
dev-python/python-iptables-1.0.0-r1: revbump, add patch for new glibc
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/python-iptables')
-rw-r--r--dev-python/python-iptables/files/python-iptables-1.0.0-ldconfig-fix.patch21
-rw-r--r--dev-python/python-iptables/python-iptables-1.0.0-r1.ebuild (renamed from dev-python/python-iptables/python-iptables-1.0.0.ebuild)4
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-iptables/files/python-iptables-1.0.0-ldconfig-fix.patch b/dev-python/python-iptables/files/python-iptables-1.0.0-ldconfig-fix.patch
new file mode 100644
index 000000000000..14fe9eae38da
--- /dev/null
+++ b/dev-python/python-iptables/files/python-iptables-1.0.0-ldconfig-fix.patch
@@ -0,0 +1,21 @@
+diff --git a/iptc/xtables.py b/iptc/xtables.py
+index cf21029..8f62164 100644
+--- a/iptc/xtables.py
++++ b/iptc/xtables.py
+@@ -4,6 +4,7 @@ import ctypes as ct
+ import os
+ import sys
+ import weakref
++import pathlib
+
+ from . import version
+ from .util import find_library, find_libc
+@@ -805,7 +806,7 @@ _lib_xtables, xtables_version = find_library(_searchlib)
+ _xtables_libdir = os.getenv("XTABLES_LIBDIR")
+ if _xtables_libdir is None:
+ import re
+- ldconfig_path_regex = re.compile('^(/.*):$')
++ ldconfig_path_regex = re.compile(r'^(/.*): \(.*$')
+ import subprocess
+ ldconfig = subprocess.Popen(
+ ('/sbin/ldconfig', '-N', '-v'),
diff --git a/dev-python/python-iptables/python-iptables-1.0.0.ebuild b/dev-python/python-iptables/python-iptables-1.0.0-r1.ebuild
index 53037c8775b5..b69547d73fee 100644
--- a/dev-python/python-iptables/python-iptables-1.0.0.ebuild
+++ b/dev-python/python-iptables/python-iptables-1.0.0-r1.ebuild
@@ -18,6 +18,10 @@ RDEPEND="net-firewall/iptables"
# tests manipulate live iptables rules, so disable them by default
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/python-iptables-1.0.0-ldconfig-fix.patch"
+)
+
distutils_enable_sphinx doc
distutils_enable_tests setup.py